summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorAhmad Draidi <a.r.draidi@redscript.org>2023-07-21 18:44:39 +0400
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-30 07:51:43 +0200
commit06166d370af19264c528e6cfc7c2a945d22bd463 (patch)
tree79cc9c778f32ae327cdc53b0d66d9559a6c93cea /gnu/packages/emacs-xyz.scm
parent34a34d64b5d79c5bc22f4dde4cff6da0afb44f1b (diff)
gnu: Add emacs-rebecca-theme.
* gnu/packages/emacs-xyz.scm (emacs-rebecca-theme): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 358b5a4fdb..73d5fc49aa 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3491,6 +3491,30 @@ read-only based on user configuration. User configuration may be prefix
directories or regex patterns.")
(license license:gpl3+))))
+;; Use latest commit since there are no tags anymore for several versions
+(define-public emacs-rebecca-theme
+ (let ((commit "4b8b5aae9099185e07c2b4cac4943c7f66a3f003")
+ (revision "0"))
+ (package
+ (name "emacs-rebecca-theme")
+ (version (git-version "1.3.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vic/rebecca-theme")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0y2kcs6zgi3dijagyz6lxbv6gi2mih8m943fhjrzkj35wfvjmhsz"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/vic/rebecca-theme")
+ (synopsis "Dark Emacs theme with purple/violet colors")
+ (description
+ "Rebecca Emacs theme is a dark theme with purple/violet colors, based on
+the @code{Dracula} theme for Emacs and the @code{Gloom} theme for Atom.")
+ (license license:expat))))
+
(define-public emacs-bbdb
(package
(name "emacs-bbdb")