summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-02-20 13:34:51 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-02-20 14:00:37 +0100
commit1551bae3de6ac60866fe5666d726205084b69b0e (patch)
treeb39050bc5538ddb085cbefebf35f86155df1fd71 /gnu/packages/emacs-xyz.scm
parent06212e8c6a6cec0311edf14de465b8004c21f84c (diff)
gnu: emacs-diff-hl: Update to 1.9.2.
* gnu/packages/emacs-xyz.scm (emacs-diff-hl): Update to 1.9.2. [description]: Use proper capitalization.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm43
1 files changed, 20 insertions, 23 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 32fc437ef1..79ad285c95 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16407,29 +16407,26 @@ actually changing the buffer's text.")
(license license:gpl3+)))
(define-public emacs-diff-hl
- ;;; XXX: Latest release is not tagged. Use commit matching version bump.
- (let ((commit "8f2e4eb345f0639c8fc41e3f7576f77ba6987655"))
- (package
- (name "emacs-diff-hl")
- (version "1.9.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dgutov/diff-hl")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1c265083zyqi33sf3mpkk1n7pyfkrzxg4dacx0b787ypbj1sls16"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/dgutov/diff-hl")
- (synopsis
- "Highlight uncommitted changes using VC")
- (description
- "@code{diff-hl-mode} highlights uncommitted changes on the side of the
-window (using the fringe, by default), allows you to jump between
-the hunks and revert them selectively.")
- (license license:gpl3+))))
+ (package
+ (name "emacs-diff-hl")
+ (version "1.9.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dgutov/diff-hl")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0nh3rrvjjddyng5j7wjrk4ls7l6cjx3fpf8ksg4kjq7wzw4abf1s"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/dgutov/diff-hl")
+ (synopsis "Highlight uncommitted changes using VC")
+ (description
+ "Diff Hl mode highlights uncommitted changes on the side of the
+window (using the fringe, by default), allows you to jump between the hunks
+and revert them selectively.")
+ (license license:gpl3+)))
(define-public emacs-diminish
;; XXX: Upstream did not tag last release.