summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorAhmad Draidi <a.r.draidi@redscript.org>2023-07-21 18:44:41 +0400
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-30 07:51:44 +0200
commit7c89bdec9ac33debb11ac55be1f29dd5626f659f (patch)
treef5d1e9ecfe41539386bcbc2cf94e941b9a96ffe7 /gnu/packages/emacs-xyz.scm
parent69427bd3c1ccb0851b564099c8e81248179f5cca (diff)
gnu: Add emacs-chocolate-theme.
* gnu/packages/emacs-xyz.scm (emacs-chocolate-theme): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 60c9ad9c5d..899ebaea3d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4221,6 +4221,31 @@ Some of its major features include:
Lock key.")
(license license:gpl3+)))
+(define-public emacs-chocolate-theme
+ (let ((commit "ccc05f7ad96d3d1332727689bf6250443adc7ec0")
+ (revision "0"))
+ (package
+ (name "emacs-chocolate-theme")
+ (version (git-version "0.2.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/SavchenkoValeriy/emacs-chocolate-theme")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1d8a9jwv9y0sncw24k840c8yyrig30f2d6q2zqlc09f05yzq9p9p"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-autothemer))
+ (home-page "https://github.com/SavchenkoValeriy/emacs-chocolate-theme")
+ (synopsis "Dark chocolatey theme for Emacs")
+ (description
+ "Chocolate theme is a dark, chocolatey, vibrant and subtle theme for
+Emacs.")
+ (license license:gpl3))))
+
(define-public emacs-chronometrist
(package
(name "emacs-chronometrist")