summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-04-30 19:12:51 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-04-30 19:13:27 +0200
commita1ffa8a69bbce0beccca0e5183bdf771cdc166ba (patch)
tree4f1653b4db19d7b024f693476b7280916191e762 /gnu/packages/emacs-xyz.scm
parent08ea18680a0afac8f6d34a7df3d4209ae70899d5 (diff)
gnu: Add emacs-atomic-chrome.
* gnu/packages/emacs-xyz.scm (emacs-atomic-chrome): New variable. Change-Id: Ib67551731a22fc576b9e01176b49a6b30ce22465
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 657d68cc58..3700f0801f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11613,6 +11613,36 @@ a RPG style habit tracker and todo list.")
(description "An Emacs port of the Atom One Dark theme from Atom.io.")
(license license:gpl3+))))
+(define-public emacs-atomic-chrome
+ (let ((commit "072a137a19d7e6a300ca3e87c0e142a7f4ccb5fb")
+ (revision "1"))
+ (package
+ (name "emacs-atomic-chrome")
+ (version (git-version "2.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alpha22jp/atomic-chrome")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0lfvqzndip8jxlc0j7pc4kxi9vi84qsqmkhaq14rj3krx79djqnq"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-websocket))
+ (home-page "https://github.com/alpha22jp/atomic-chrome")
+ (synopsis
+ "Edit browser text area with Emacs using Atomic Chrome or Ghost Text")
+ (description
+ "This is an Emacs version of Atomic Chrome and Ghost Text,
+which are extensions that allows you to edit text areas of the browser in
+Emacs.
+
+The input on Emacs is reflected to the browser instantly and continuously.
+You can use both the browser and Emacs at the same time. They are updated to
+the same content bi-directionally.")
+ (license license:gpl2+))))
+
(define-public emacs-zenburn-theme
(package
(name "emacs-zenburn-theme")