summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorAhmad Draidi <a.r.draidi@redscript.org>2023-07-07 08:41:42 +0400
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-16 09:18:09 +0200
commit1ef314fa58073cc688f536a38580ab9db2bd9f1d (patch)
tree7f1ff10c4feddba5d5cb3107faee27d7365ffba1 /gnu/packages/emacs-xyz.scm
parentc6dad0178af1c13e540a6e4ad51a2dd72b3910e0 (diff)
gnu: Add emacs-weyland-yutani-theme.
* gnu/packages/emacs-xyz.scm (emacs-weyland-yutani-theme): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f26fe56dd1..838a62e64e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -35807,6 +35807,29 @@ uncluttered design pattern to achieve optimal focus and readability for code
syntax highlighting and UI components.")
(license license:expat)))
+(define-public emacs-weyland-yutani-theme
+ (let ((commit "e89a63a62e071180c9cdd9067679fadc3f7bf796")
+ (revision "0"))
+ (package
+ (name "emacs-weyland-yutani-theme")
+ (version (git-version "0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jstaursky/weyland-yutani-theme")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0gxlz9b7fvbjkqxsyb4l75g7jsxyms0i1vpnb6y499hl115akcaz"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/jstaursky/weyland-yutani-theme")
+ (synopsis "Emacs theme based on the Alien movie franchise")
+ (description
+ "Weyland Yutani is a dark Emacs theme based on the Alien movie
+franchise.")
+ (license license:gpl3+))))
+
(define-public emacs-janet-mode
(let ((commit "2f5bcabcb6953e1ed1926ba6a2328c453e8b4ac7"))
(package