summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2024-06-06 21:22:17 +0200
committerLudovic Courtès <ludo@gnu.org>2024-06-13 22:47:52 +0200
commitb8bbc186f04085a1721e9f7a4730d8a4291b1079 (patch)
tree309e25fcce6b58fb384225972547c973dd1bf47a /gnu/packages/emacs-xyz.scm
parent10d8bbdabb9fb9f2041d2ab419906cb23b874a49 (diff)
gnu: Add emacs-casual-dired.
* gnu/packages/emacs-xyz.scm (emacs-casual-dired): New variable. Change-Id: I5208b1699baa94a610d27d2d04d5f54015d9905d Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3d4cf0720f..49292880fa 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -139,6 +139,7 @@
;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
;;; Copyright © 2024 dan <i@dan.games>
;;; Copyright © 2024 Ilya Chernyshov <ichernyshovvv@gmail.com>
+;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32844,6 +32845,32 @@ You might want to use this to globally set dir-local variables that apply to
all of your projects, then override or add variables on a per-project basis.")
(license license:gpl3+))))
+(define-public emacs-casual-dired
+ (package
+ (name "emacs-casual-dired")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kickingvegas/casual-dired")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "07dn2nfjvg348qy7kfn1kywclw9g71x8j85ilwz26pp9hv64qhmc"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "lisp"))))))
+ (home-page "https://github.com/kickingvegas/casual-dired")
+ (synopsis "Transient-based porcelain for dired")
+ (description
+ "Casual Dired is an opinionated Transient-based porcelain for Emacs Dired.")
+ (license license:gpl3+)))
+
(define-public emacs-calibredb
(package
(name "emacs-calibredb")