summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-02-28 21:29:24 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-02-28 21:29:30 +0100
commitbc36327398440d8f65e72a82c8fe164ff36fdf06 (patch)
tree6260982c59d2f6a4fe6eda58d729ba506391c36d /gnu/packages/emacs-xyz.scm
parentbc6840316c665e5959469e5c857819142cc4a47b (diff)
gnu: Add emacs-activities.
* gnu/packages/emacs-xyz.scm (emacs-activities): New variable. Change-Id: Ie1a0c88492f7aff47e2b0af8b8ef5e03143b7d21
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b0182056cb..accdcc3ee8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -368,6 +368,35 @@
"This package allows using Ace jump to a candidate in Helm window.")
(license license:gpl3+))))
+(define-public emacs-activities
+ (package
+ (name "emacs-activities")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://elpa.gnu.org/packages/activities-" version ".tar"))
+ (sha256
+ (base32 "0ng9sgajcpal881s3kavkmz0fc38f2h207hpqj62cf14z7bsk0zk"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-persist))
+ (home-page "https://github.com/alphapapa/activities.el")
+ (synopsis "Save/restore sets of windows, tabs/frames, and their buffers")
+ (description
+ "Inspired by Genera's and KDE's concepts of \"activities\", this library
+allows the user to select an \"activity\", the loading of which restores a
+window configuration into a @code{tab-bar} tab or frame, along with the
+buffers shown in each window. Saving an activity saves the state for later
+restoration. Switching away from an activity saves the last-used state for
+later switching back to, while still allowing the activity's initial or
+default state to be restored on demand. Resuming an activity loads the
+last-used state, or the initial/default state when a universal argument is
+provided. The implementation uses the bookmark system to save buffers
+states–that is, any major mode that supports the bookmark system is
+compatible.")
+ (license license:gpl3+)))
+
(define-public emacs-bookmark-plus
(package
(name "emacs-bookmark-plus")