summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-24 09:50:41 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-24 10:42:42 -0500
commite479920cfd4208407d10939881a438f19ef289f7 (patch)
treeb8e79f69ebb98bca3a6d97f079b4e81c068b69b1 /gnu/packages/emacs-xyz.scm
parent1348be9115d15f8066d3d194d2c8d38ffa61fbae (diff)
gnu: emacs-yasnippet: Update to 0.14.0-0.297546f.
* gnu/packages/emacs-xyz.scm (emacs-yasnippet): Update to 0.14.0-0.297546f. Remove fix-tests patch. * gnu/packages/patches/emacs-yasnippet-fix-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it. Change-Id: I3fda2bb3d879d88f06f9d814b6c8d835d9eafc9f
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm65
1 files changed, 33 insertions, 32 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ad8c72e97d..7d3e2dc17e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17919,39 +17919,40 @@ the Emacs TempEl package.")
(license license:gpl3+))))
(define-public emacs-yasnippet
- (package
- (name "emacs-yasnippet")
- (version "0.14.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/joaotavora/yasnippet")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0via9dzw8m5lzymg1h78xkwjssh39zr3g6ccyamlf1rjzjsyxknv"))
- (patches
- (search-patches "emacs-yasnippet-fix-empty-snippet-next.patch"
- "emacs-yasnippet-fix-tests.patch"))))
- (build-system emacs-build-system)
- (arguments
- `(#:tests? #t
- #:test-command '("emacs" "--batch"
- "-l" "yasnippet-tests.el"
- "-f" "ert-run-tests-batch-and-exit")
- #:phases
- (modify-phases %standard-phases
- ;; Set HOME, otherwise test-rebindings fails.
- (add-before 'check 'set-home
- (lambda _
- (setenv "HOME" (getcwd))
- #t)))))
- (home-page "https://github.com/joaotavora/yasnippet")
- (synopsis "Yet another snippet extension for Emacs")
- (description "YASnippet is a template system for Emacs. It allows you to
+ ;; The latest release is more than 5 years old, has test problems.
+ (let ((revision "0")
+ (commit "297546f0853a6a51f5b05e954d0c6aea8caa5ec2"))
+ (package
+ (name "emacs-yasnippet")
+ (version (git-version "0.14.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/joaotavora/yasnippet")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0b1fdigwjshfim6zyzkn2wa6k8xd4qlafrf7zgj5bsx6alrzac8v"))
+ (patches
+ (search-patches "emacs-yasnippet-fix-empty-snippet-next.patch"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:tests? #t
+ #:test-command '("emacs" "--batch"
+ "-l" "yasnippet-tests.el"
+ "-f" "ert-run-tests-batch-and-exit")
+ #:phases
+ (modify-phases %standard-phases
+ ;; Set HOME, otherwise test-rebindings fails.
+ (add-before 'check 'set-home
+ (lambda _
+ (setenv "HOME" (getcwd)))))))
+ (home-page "https://github.com/joaotavora/yasnippet")
+ (synopsis "Yet another snippet extension for Emacs")
+ (description "YASnippet is a template system for Emacs. It allows you to
type an abbreviation and automatically expand it into function templates.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-yasnippet-snippets
(package