summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-02-22 14:48:50 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-02-22 16:16:49 +0100
commiteefd12d4046b03917433d1efadc339f862684833 (patch)
treeeb4b8152650f00ddefe1b94cbbd6ec91b739eea1 /gnu/packages/emacs-xyz.scm
parent5ea5124cb5e416508e83db73ee932f74a8a237e0 (diff)
gnu: emacs-nodejs-repl: Improve package style.
* gnu/packages/emacs-xyz.scm (emacs-nodejs-repl)[arguments]: Use G-expressions. Use SEARCH-INPUT-FILES. Remove trailing #T. Remove unnecessary call to MAKE-FILE-WRITABLE. Change-Id: I9da1e24566359970cbf24129acb67f9f0610fb80
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm43
1 files changed, 20 insertions, 23 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f8cf5bf986..2bab584478 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14146,29 +14146,26 @@ an Emacs buffer.")
(native-inputs
(list emacs-ert-expectations))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'set-shell
- ;; Setting the SHELL environment variable is required for the tests
- ;; to find sh.
- (lambda _
- (setenv "SHELL" (which "sh"))
- #t))
- (add-after 'unpack 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((node (assoc-ref inputs "node")))
- ;; Specify the absolute file names of the various
- ;; programs so that everything works out-of-the-box.
- (make-file-writable "nodejs-repl.el")
- (emacs-substitute-variables
- "nodejs-repl.el"
- ("nodejs-repl-command"
- (string-append node "/bin/node")))))))
- #:tests? #t
- #:test-command '("emacs" "-Q" "--batch"
- "-L" "."
- "-l" "test/test.el"
- "-f" "ert-run-tests-batch-and-exit")))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'set-shell
+ ;; Setting the SHELL environment variable is required for the tests
+ ;; to find sh.
+ (lambda _
+ (setenv "SHELL" (which "sh"))))
+ (add-after 'unpack 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((node (search-input-file inputs "/bin/node")))
+ ;; Specify the absolute file names of the various
+ ;; programs so that everything works out-of-the-box.
+ (emacs-substitute-variables "nodejs-repl.el"
+ ("nodejs-repl-command" node))))))
+ #:tests? #t
+ #:test-command #~(list "emacs" "-Q" "--batch"
+ "-L" "."
+ "-l" "test/test.el"
+ "-f" "ert-run-tests-batch-and-exit")))
(home-page "https://github.com/abicky/nodejs-repl.el")
(synopsis "Node.js REPL inside Emacs")
(description