summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorBrian Kubisiak <brian@kubisiak.com>2022-04-26 21:26:22 -0700
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-09-25 15:41:44 +0200
commit2d141896ec48649f2a3048f679cf64798f26b788 (patch)
treeaffa9c771245d1961a1981f1f0b414bc019024a2 /gnu/packages/emacs-xyz.scm
parentcee9dc06ec22031ed8ff2b4bd6bc7b1c44b147ce (diff)
gnu: Add emacs-color-theme-solarized.
* gnu/packages/emacs-xyz (emacs-color-theme-solarized): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bc3fc2e950..e48757ee69 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9128,6 +9128,40 @@ variants.")
package provides a light and a dark variant.")
(license license:gpl3+)))
+(define-public emacs-color-theme-solarized
+ ;; From 2017-10-24. No releases available.
+ (let ((commit "f3ca8902ea056fb8e46cb09f09c96294e31cd4ee")
+ (revision "0"))
+ (package
+ (name "emacs-color-theme-solarized")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/sellout/emacs-color-theme-solarized")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16d7adqi07lzzr0qipl1fbag9l8kiyr3xrqxi528pimcisbg85d3"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ ;; These are intended for old versions of Emacs and do not
+ ;; compile with emacs>=24.
+ (add-before 'install 'remove-color-theme
+ (lambda _
+ (delete-file "./color-theme-solarized.el")
+ (delete-file "./color-theme-solarized-pkg.el"))))))
+ (home-page "https://github.com/sellout/emacs-color-theme-solarized")
+ (synopsis "Solarized color scheme for Emacs")
+ (description
+ "This package provides Emacs highlighting using Ethan Schoonover’s
+Solarized color scheme.")
+ (license license:expat))))
+
(define-public emacs-poet-theme
(let ((commit "16eb694f0755c04c4db98614d0eca1199fddad70")
(revision "1"))