summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-01-21 23:54:52 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-01-22 00:20:56 +0100
commit9e9c1613ddfb6147a59aaff85bfe3ee6b98da61c (patch)
tree8e96c50be45c38c09f2f3c22420c2e9946665c69 /gnu/packages/emacs-xyz.scm
parenta9d5628f5babfc4e63b632e6454c3ca657174e09 (diff)
gnu: emacs-org-fc: Update to 0.4.0.
* gnu/packages/emacs-xyz.scm (emacs-org-fc): Update to 0.4.0. [arguments]<#:phases>: Fix build error by adding missing (require 'eieio). <#:test-command>: Load more tests. [native-inputs]: Add EMACS-EL-MOCK. Change-Id: Ibdaf38f3dd8f3018bf2b7b53cd94626b983fc953
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm91
1 files changed, 49 insertions, 42 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 20bf05b679..48f437131b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4843,52 +4843,59 @@ that the binary uses instead of the actual binary contents.")
(define-public emacs-org-fc
(package
- (name "emacs-org-fc")
- (version "0.3.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~l3kn/org-fc")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "17cdn4sdyb9fs9w725l155lb74inzdn86m8y62m6hn4dgb5l4spm"))))
- (build-system emacs-build-system)
- (arguments
- (list
- #:include #~(cons* "\\.awk$" "\\.org$" %default-include)
- #:exclude #~(cons "^tests/" %default-exclude)
- #:tests? #t
- #:test-command #~(list "emacs" "--batch"
- "-L" "."
- "-L" "tests/"
- "-l" "tests/org-fc-filter-test.el"
- "-l" "tests/org-fc-indexer-test.el"
- "-l" "tests/org-fc-review-data-test.el"
- "-f" "ert-run-tests-batch-and-exit")
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'qualify-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((find (search-input-file inputs "/bin/find"))
- (gawk (search-input-file inputs "/bin/gawk"))
- (xargs (search-input-file inputs "/bin/xargs")))
- (substitute* "org-fc-awk.el"
- (("\"find ") (string-append "\"" find " "))
- (("\"gawk ") (string-append "\"" gawk " "))
- (("\"xargs ") (string-append "\"" xargs " ")))))))))
- (inputs (list findutils gawk))
- (propagated-inputs (list emacs-hydra))
- (home-page "https://www.leonrische.me/fc/index.html")
- (synopsis "Spaced repetition system for Emacs Org mode")
- (description
- "Org-fc is a spaced-repetition system for Emacs' Org mode.
+ (name "emacs-org-fc")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~l3kn/org-fc")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09s493p2ccvc1zd297kldwinhn6imnmyik98qc56ndb7dp0dwa0x"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:include #~(cons* "\\.awk$" "\\.org$" %default-include)
+ #:exclude #~(cons "^tests/" %default-exclude)
+ #:tests? #t
+ #:test-command #~(list "emacs" "--batch"
+ "-L" "."
+ "-L" "tests/"
+ "-l" "tests/org-fc-card-test.el"
+ "-l" "tests/org-fc-filter-test.el"
+ "-l" "tests/org-fc-indexer-test.el"
+ "-l" "tests/org-fc-review-data-test.el"
+ "-f" "ert-run-tests-batch-and-exit")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'qualify-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((find (search-input-file inputs "/bin/find"))
+ (gawk (search-input-file inputs "/bin/gawk"))
+ (xargs (search-input-file inputs "/bin/xargs")))
+ (substitute* "org-fc-awk.el"
+ (("\"find ") (string-append "\"" find " "))
+ (("\"gawk ") (string-append "\"" gawk " "))
+ (("\"xargs ") (string-append "\"" xargs " "))))))
+ (add-after 'unpack 'require-eieio
+ (lambda _
+ (substitute* "org-fc-core.el"
+ (("\\(require 'cl-lib\\)" line)
+ (string-append line "\n(require 'eieio)"))))))))
+ (native-inputs (list emacs-el-mock))
+ (inputs (list findutils gawk))
+ (propagated-inputs (list emacs-hydra))
+ (home-page "https://www.leonrische.me/fc/index.html")
+ (synopsis "Spaced repetition system for Emacs Org mode")
+ (description
+ "Org-fc is a spaced-repetition system for Emacs' Org mode.
It allows you to mark headlines in a file as flashcards, turning pieces of
knowledge you want to learn into a question-answer test. These cards are
reviewed at regular interval. After each review, the next review interval is
calculated based on how well you remembered the contents of the card.")
- (license license:gpl3+)))
+ (license license:gpl3+)))
(define-public emacs-font-lock+
(let ((commit "aa1c82d05c9222b09099a0ccd7468e955497940c")