summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorThanos Apollo <public@thanosapollo.org>2024-07-03 08:02:55 +0300
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-07-07 08:04:47 +0200
commitfee360f85384fb06f7d0c46891126b1f85c9c740 (patch)
tree043e8328d3e4deb771087a88d91a1a206c9f68e7 /gnu/packages/emacs-xyz.scm
parent74d723b4a8185518468f9dff49acef7cd814ce14 (diff)
gnu: Add emacs-eshell-git-prompt.
gnu/packages/emacs-xyz.scm (emacs-eshell-git-prompt): New variable. Change-Id: If3e7f918708d9b57295b368f5d7c5fc7b18d73cf Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 76cd340e5e..c82e264930 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -35182,6 +35182,28 @@ when the command was not found in Eshell. The suggestions are found after the
commands that bear resemblance to the input command.")
(license license:gpl3+)))
+(define-public emacs-eshell-git-prompt
+ (let ((commit "dfcf9cd93add6763e2c46603b0323274d4c22906"))
+ (package
+ (name "emacs-eshell-git-prompt")
+ (version "0.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xuchunyang/eshell-git-prompt")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13b7nr0819pgzyvh0szi0zjyazgpxmsbqcz65cccyhh2pq48zb7j"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-dash))
+ (home-page "https://github.com/xuchunyang/eshell-git-prompt")
+ (synopsis "Themes for Emacs Shell (Eshell) prompt.")
+ (description "This package provides a variety of themes for Emacs Shell (Eshell) prompt.")
+ (license license:gpl3+))))
+
(define-public emacs-unfill
(package
(name "emacs-unfill")