summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2022-11-20 14:04:44 +0800
committerChristopher Baines <mail@cbaines.net>2022-11-21 14:25:13 +0000
commit426afbad5fced86899987ae7c8499bb47c953872 (patch)
treeb3badde0e4a9a5d923aa081ace3398d56cb1addf /gnu/packages/emacs-xyz.scm
parent9283c80e604324f5449b5a8daf94285cdc6a8604 (diff)
gnu: Add emacs-bbdb-vcard.
* gnu/packages/emacs-xyz.scm (emacs-bbdb-vcard): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a92ab71a97..b982518448 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2841,6 +2841,34 @@ like. It can be linked with various Emacs mail clients (Message and Mail
mode, Rmail, Gnus, MH-E, and VM). BBDB is fully customizable.")
(license license:gpl3+)))
+(define-public emacs-bbdb-vcard
+ ;; No release since Dec 1, 2013.
+ (let ((version "0.4.1") ;3d79fdb4200a64a043e203a3baac95c936095b52, not tagged
+ (revision "88")
+ (commit "113c66115ce68316e209f51ebce56de8dded3606"))
+ (package
+ (name "emacs-bbdb-vcard")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tohojo/bbdb-vcard")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1sr5kd2gvw1b4hl147yb60cgx6j730vdnpyr09p7vmpw65hzwlwm"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-bbdb))
+ (home-page "https://github.com/tohojo/bbdb-vcard")
+ (synopsis
+ "vCard Import and Export for The Insidious Big Brother Database (BBDB)")
+ (description
+ "@code{bbdb-vcard.el} imports and exports vCards (version 3.0) as
+defined in RFC 2425 and RFC 2426 to/from The Insidious Big Brother Database
+(BBDB). Version 2.1 vCards are converted into version 3.0 on import.")
+ (license license:gpl2+))))
+
(define-public emacs-beacon
(package
(name "emacs-beacon")