summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-08-31 19:56:25 -0500
committerBrett Gilio <brettg@gnu.org>2020-08-31 19:56:25 -0500
commit2b6333c63b42acd349f2152468b91fd929c81e00 (patch)
tree1fdd255d06c89c334deca27b963738b73e97254f /gnu/packages/emacs-xyz.scm
parent03b27b396bd653797c5c3d1c170b39e9c1130415 (diff)
gnu: Add emacs-scpaste.
* gnu/packages/emacs-xyz.scm (emacs-scpaste): New variable.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3036004cee..aa9a1436fb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -24424,3 +24424,31 @@ directly, or indirectly, as in ox-hugo), it will fetch a given list of
web feed files and correctly parse and format the elements to be
displayed for sharing.")
(license license:gpl3+)))
+
+(define-public emacs-scpaste
+ (let ((commit "cd4fa0aafecd839736e0b6cba68b4fc4d7045472")
+ (revision "0"))
+ (package
+ (name "emacs-scpaste")
+ (version "0.6.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~technomancy/scpaste")
+ (commit commit)))
+ (file-name (git-file-name name commit))
+ (sha256
+ (base32
+ "1nvwbwl26z03963g9c82b3ggm39r95z1vp7c9qsa9mjm46dyq27w"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-htmlize" ,emacs-htmlize)))
+ (home-page "https://git.sr.ht/~technomancy/scpaste")
+ (synopsis "Emacs-based static HTML pastebin")
+ (description "This library will place an HTML copy of a
+buffer on an active webserver to which the user has SSH access.
+It is similar in purpose to services such as Gist or Pastebin,
+but is much simpler since it assumes the user has access to a
+publically-accessible HTTP server.")
+ (license license:gpl3+))))