summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-04-28 14:45:35 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-28 14:45:35 +0200
commit7d62fa206b701504b110f253e3efb217eed475ad (patch)
tree8a2e44fb2560144d3b029085a560c1042e163423 /gnu/packages/emacs-xyz.scm
parentc5db31d4141669d09c1cd8b37eb270c2fe23c7cf (diff)
parentcd8dce8ac4224d425f13b3c0776884c87ff43562 (diff)
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 13a4c68ace..92c2dd3184 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2600,6 +2600,31 @@ definitions, modules and classes, display method documentation and provide
method and constant name completion.")
(license license:gpl3+)))
+(define-public emacs-robot-mode
+ (let ((commit "32846e7e80ae3471b7c07f9709dcaa4f9b9ed4a0")
+ (revision "1"))
+ (package
+ (name "emacs-robot-mode")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ ;; A better maintained fork of robot-mode.
+ (url "https://github.com/jvalkeejarvi/robot-mode.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1i8wf7m0gml8zvvmlgppjzv78b432686p1qdbzgclc7qfcvzag0d"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-s" ,emacs-s)))
+ (home-page "https://github.com/jvalkeejarvi/robot-mode")
+ (synopsis "Emacs mode for Robot Framework")
+ (description "This major mode facilitates editing Robot Framework source
+files with features such as syntax highlighting, comments, finding keywords,
+completing keywords and smart indentation.")
+ (license license:gpl3+))))
+
(define-public emacs-rspec
(package
(name "emacs-rspec")