summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorAdam <rndd@tuta.io>2020-10-28 14:02:26 +0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-10-29 10:15:51 +0100
commitc791bef41e5fa5663fd30f6759da9ae95f6295f9 (patch)
tree3294195808a6e456e4949a364737fcc5d1de94dc /gnu/packages/emacs-xyz.scm
parent4a5ea2f06e52f46a24893babe2220681d75a9b77 (diff)
gnu: Add emacs-powershell.
* gnu/packages/emacs-xyz.scm (emacs-powershell): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d175cae4e1..49630377b5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13238,6 +13238,30 @@ literate programming tools for exporting, weaving and tangling.")
"Edit YAML files for Ansible containing embedded Jinja2 templating.")
(license license:gpl3+))))
+(define-public emacs-powershell
+ ;; Tagged branch 0.1 is outdated (2015).
+ (let ((revision "0")
+ (commit "d1b3f95669343399f199f291ef76c09a0ede5e60"))
+ (package
+ (name "emacs-powershell")
+ (build-system emacs-build-system)
+ (version (git-version "0.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jschaf/powershell.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1cxhzaaig88zhylyycvb3849r85j1ijqklnh9zbqsfl2zhpb0g5c"))))
+ (home-page "https://github.com/jschaf/powershell.el")
+ (synopsis "Emacs mode for editing PowerShell scripts")
+ (description
+ "Powershell is an Emacs major mode for editing and running
+Microsoft PowerShell files.")
+ (license license:gpl3+))))
+
(define-public emacs-polymode-org
(package
(name "emacs-polymode-org")