summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2020-10-10 12:00:30 -0400
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-03 11:47:47 +0100
commitdb1ccf03b727c469d14f7552353c9e5fe4fa036e (patch)
tree44cc4b1f380c3f08c4f321bbce1894e2d6e74b0a /gnu/packages/emacs-xyz.scm
parentb107a19ffb6a6abb7bde3436f3fa359071bd1f5c (diff)
gnu: emacs-modus-vivendi-theme: Update to 0.13.0.
* gnu/packages/emacs-xyz.scm (emacs-modus-vivendi-theme): Update to 0.13.0. [source]: Use GitHub instead of GNU ELPA, as GNU ELPA is out of date. [arguments]: Add phase to remove "modus-operandi-theme.el". Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm19
1 files changed, 14 insertions, 5 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a145f6a378..9c606dea97 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22898,15 +22898,24 @@ standard. This is the highest standard of its kind.")
(define-public emacs-modus-vivendi-theme
(package
(name "emacs-modus-vivendi-theme")
- (version "0.12.0")
+ (version "0.13.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://elpa.gnu.org/packages/"
- "modus-vivendi-theme-" version ".el"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/protesilaos/modus-themes")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "01f6z5xjnmki1k9m83jwva42lxidb31pdpwm4wpxjzxqmb96picn"))))
+ (base32 "0i6n3pzrmlgabsijy6z0hhs71q7g99yagwr2m33lr30skqc9rvdn"))))
(build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-other-theme
+ (lambda _
+ (delete-file "modus-operandi-theme.el")
+ #t)))))
(home-page "https://gitlab.com/protesilaos/modus-themes")
(synopsis "Accessible dark theme (WCAG AAA)")
(description