summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-04-13 01:11:47 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-14 17:42:11 +0200
commitdf04eeec75dd128437a27cd86c61d84e084b8f2d (patch)
treed1749f755a547df74660cfcb7296134d3dc981b0 /gnu/packages/emacs-xyz.scm
parent87b6896ed746e90514922087ef7fdc6398a4df0d (diff)
gnu: Add emacs-peep-dired.
* gnu/packages/emacs-xyz.scm (emacs-peep-dired): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f1c0b9c27e..698357ac19 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14885,6 +14885,30 @@ support JSX syntax.")
expanding regions of text without modifying the actual contents.")
(license license:expat))))
+(define-public emacs-peep-dired
+ (let ((commit "c88a9a3050197840edfe145f11e0bb9488de32f4")
+ (version "0")
+ (revision "1"))
+ (package
+ (name "emacs-peep-dired")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/asok/peep-dired")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wy5qpnfri1gha2cnl6q20qar8dbl2mimpb43bnhmm2g3wgjyad6"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/asok/peep-dired")
+ (synopsis "Preview files in another window")
+ (description "This package provides a minor mode that allows files to be
+previewed by scrolling up and down within a @code{dired} buffer.")
+ (license license:gpl3+))))
+
(define-public emacs-semantic-refactor
;; The last release, 0.5, was made on 2015-07-26 and there have been 47
;; commits since then.