summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-06 13:51:27 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-06 13:51:27 +0100
commit5f0cc5f9fbdc8d02628ce7b9c5aa0acb566f41aa (patch)
treeec278e66b2fe73dc38c132d617d98836e6b17da4 /gnu/packages/emacs-xyz.scm
parent3be86365b34ae1ebac2b93f6ddd7cf09c543c94a (diff)
gnu: emacs-company-math: Update to 1.4.
* gnu/packages/emacs-xyz.scm (emacs-company-math): Update to 1.4. [synopsis]: Slightly shorten it. [description]: Use proper capitalization.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm48
1 files changed, 23 insertions, 25 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 28e8d39234..ffed61aadc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2016, 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
;;; Copyright © 2016, 2019 Alex Griffin <a@ajgrf.com>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
@@ -5402,30 +5402,28 @@ features:
(license license:gpl3+)))
(define-public emacs-company-math
- (let ((commit "600e49449644f6835f9dc3501bc58461999e8ab9")
- (revision "1"))
- (package
- (name "emacs-company-math")
- (version (git-version "1.3" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/vspinu/company-math")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1ps2lpkzn8mjbpcbvvy1qz3xbgrh6951x8y9bsd1fm32drdph9lh"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-math-symbol-lists" ,emacs-math-symbol-lists)
- ("emacs-company" ,emacs-company)))
- (home-page "https://github.com/vspinu/company-math")
- (synopsis "Completion backends for Unicode math symbols and @code{LaTeX} tags")
- (description "This package provides a backend for use with
-@code{company-mode} allowing for completion of common math symbols.")
- (license license:gpl3+))))
+ (package
+ (name "emacs-company-math")
+ (version "1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vspinu/company-math")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1y1fw926insgdl7ib9ynxjrxf3p6wfjkfxvf5vgdca7267cvcll1"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-math-symbol-lists" ,emacs-math-symbol-lists)
+ ("emacs-company" ,emacs-company)))
+ (home-page "https://github.com/vspinu/company-math")
+ (synopsis "Completion backends for math symbols and @code{LaTeX} tags")
+ (description
+ "This package provides a backend for use with Company mode allowing for
+completion of common math symbols.")
+ (license license:gpl3+)))
(define-public emacs-compdef
(let ((commit "67104a38763cc819644f711248b170a43bce151b")