summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2021-01-27 22:05:43 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-28 14:18:12 +0100
commitc2245ac23a581e3152a683da749b4dae5358d6e3 (patch)
treeb365ddb77f29536c6292460b553bffcccf97ec7e /gnu/packages/emacs-xyz.scm
parenta6b50a183258c011a7f33715883a7649316ca9d4 (diff)
gnu: Add emacs-theme-magic.
* gnu/packages/emacs-xyz.scm (emacs-theme-magic): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm46
1 files changed, 45 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a34e31337c..85356f2281 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -76,7 +76,7 @@
;;; Copyright © 2020 Fredrik Salomonsson <plattfot@gmail.com>
;;; Copyright © 2020 Ryan Desfosses <rdes@protonmail.com>
;;; Copyright © 2020 Eric Bavier <bavier@posteo.net>
-;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
+;;; Copyright © 2020, 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2020 Peng Mei Yu <i@pengmeiyu.com>
;;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
;;; Copyright © 2020 Marco Grassi <marco.au.grassi98@protonmail.com>
@@ -725,6 +725,50 @@ this one is much simpler and much more consistent. When using this package,
then only the color of the mode line changes when a window becomes in-/active.")
(license license:gpl3+)))
+(define-public emacs-theme-magic
+ ;; No tagged release upstream, but the commit below correspond to the 0.2.3
+ ;; release.
+ (let ((commit "844c4311bd26ebafd4b6a1d72ddcc65d87f074e3")
+ (revision "0"))
+ (package
+ (name "emacs-theme-magic")
+ (version "0.2.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jcaw/theme-magic")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10gkg7jh1s1484gm66a87zr7x8vmv00s7gfd0w2pj47nqf98g8hz"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(
+ ;; Include Pywal interaction scripts.
+ #:include (cons "^python/" %default-include)
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-exec-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((files '("theme-magic.el" "python/wal_change_colors.py"))
+ (python (assoc-ref inputs "python"))
+ (python-pywal (assoc-ref inputs "python-pywal")))
+ (substitute* files
+ (("\"python\"") (string-append "\"" python "/bin/python3\""))
+ (("\"wal\"") (string-append "\"" python-pywal "/bin/wal\""))))
+ #t)))))
+ (inputs
+ `(("python" ,python)
+ ("python-pywal" ,python-pywal)))
+ (home-page "https://github.com/jcaw/theme-magic")
+ (synopsis "Generate and apply color palettes based on your Emacs theme")
+ (description
+ "This package provides a command to extract the colors from your Emacs
+theme and apply them to the rest of Linux with Pywal. Pywal only applies your
+theme to the current session.")
+ (license license:gpl3+))))
+
(define-public emacs-treepy
(package
(name "emacs-treepy")