summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-24 13:47:33 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-24 16:33:29 -0500
commite1af6c058e92ff4b0ea91c382c55762384d0a733 (patch)
treeefe794e1b084c1532969e42394877cf51c3094b2 /gnu/packages/emacs-xyz.scm
parentfc68f611929df574c040e15f6653cee63401f8e2 (diff)
gnu: Add emacs-counsel-bbdb.
* gnu/packages/emacs-xyz.scm (emacs-counsel-bbdb): New variable.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a3d66bfd62..163eb6791b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -31,7 +31,7 @@
;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Mike Gerwitz <mtg@gnu.org>
-;;; Copyright © 2017, 2018, 2019, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2017, 2018, 2019, 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Sohom Bhattacharjee <soham.bhattacharjee15@gmail.com>
;;; Copyright © 2018, 2019 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2018, 2019, 2020, 2021 Pierre Neidhardt <mail@ambrevar.xyz>
@@ -1846,6 +1846,34 @@ like. It can be linked with various Emacs mail clients (Message and Mail
mode, Rmail, Gnus, MH-E, and VM). BBDB is fully customizable.")
(license license:gpl3+)))
+(define-public emacs-counsel-bbdb
+ (package
+ (name "emacs-counsel-bbdb")
+ (version "20181128.1320")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://melpa.org/packages/counsel-bbdb-"
+ version ".el"))
+ (sha256
+ (base32
+ "03g3lk8hz9a17vf5r16x054bhyk8xsbnfq0div8ig13fmhqi159q"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-ivy" ,emacs-ivy)))
+ (home-page "https://github.com/redguard/counsel-bbdb")
+ (synopsis "Ivy interface for BBDB")
+ (description "This Ivy extension enables the use of @code{ivy-mode} to input
+email addresses from BBDB efficiently. The main functions are:
+@table @code
+@item counsel-bbdb-complete-mail to input email addresses;
+@item counsel-bbdb-reload' to reload contacts from BBDB database;
+@item counsel-bbdb-expand-mail-alias to expand mail alias.
+@end table
+Since @code{counsel-bbdb} is based on @code{ivy-mode}, all Ivy key bindings
+are supported. For example, after @samp{C-u M-x counsel-bbdb-complete-mail},
+you can press @samp{C-M-n} to input multiple email addresses.")
+ (license license:gpl3+)))
+
(define-public emacs-bluetooth
(package
(name "emacs-bluetooth")