summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-17 15:06:15 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-17 15:06:15 +0100
commitfe0ab6027427bcba927378027aef9d1e1cc3d8df (patch)
treebd97e4382502778a3e06b821980ac44e5dde7bca /gnu/packages/emacs-xyz.scm
parent5b5b7336f4817d9c7944649de14b6fa5b1e4806e (diff)
gnu: emacs-cort: Update to 7.1.0.
* gnu/packages/emacs-xyz.scm (emacs-cort): Update to 7.1.0.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm52
1 files changed, 24 insertions, 28 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3b462e790e..6474223afd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20590,34 +20590,30 @@ functions to ensure they are called with the right arguments during testing.")
(license license:gpl3+)))
(define-public emacs-cort
- ;; Choosing a recent commit to fix some bugs.
- ;; https://github.com/conao3/cort.el/issues/106
- (let ((commit "495c3972b92b57a0cb5dd65ce5de9d3c6b8b6509")
- (revision "1"))
- (package
- (name "emacs-cort")
- (version (git-version "3.0.5" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/conao3/cort.el")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0f4irq1arh9c7lf9a5bla25am0jy5r6lj8ayb8k9k7lrirzhyk99"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-ansi" ,emacs-ansi)))
- (arguments
- `(#:tests? #t
- #:test-command '("emacs" "--batch" "--quick"
- "--directory=." "--load=cort-tests.el"
- "--funcall=cort-test-run")))
- (home-page "https://github.com/conao3/cort.el")
- (synopsis "Unit test framework for the Emacs Lisp")
- (description "@code{cort} is a lightweight Emacs Lisp unit test library.")
- (license license:gpl3+))))
+ (package
+ (name "emacs-cort")
+ (version "7.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/conao3/cort.el")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03c223nczpbdkjmq69panhbsq2a0zj20w329jgj4c0zsj8m1a32a"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-ansi" ,emacs-ansi)))
+ (arguments
+ `(#:tests? #t
+ #:test-command '("emacs" "--batch" "--quick"
+ "--directory=." "--load=cort-tests.el"
+ "--funcall=cort-test-run")))
+ (home-page "https://github.com/conao3/cort.el")
+ (synopsis "Unit test framework for the Emacs Lisp")
+ (description "@code{cort} is a lightweight Emacs Lisp unit test library.")
+ (license license:gpl3+)))
(define-public emacs-wordnut
(let ((commit "feac531404041855312c1a046bde7ea18c674915")