summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-03-12 22:40:07 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-13 13:53:49 +0100
commitc0641c0965ed324968c9ea307c91a1a8c346f5e4 (patch)
treebd24d541a5878dfa0cd5e6c48912288e5dfc2a13 /gnu/packages/emacs-xyz.scm
parentfe533002636be8f172b154ce7e54c6ffe2a5c7c9 (diff)
gnu: Add emacs-org-msg.
* gnu/packages/emacs-xyz.scm (emacs-org-msg): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a696d27e6e..74ab3c889b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6658,6 +6658,32 @@ useful for sending tables, fontified source code, and inline images in
email.")
(license license:gpl3+)))
+(define-public emacs-org-msg
+ ;; No git tags. The commit below corresponds to the release of version 3.3.
+ (let ((commit "89e746c0a864031eef940758230bc7263a6f2289"))
+ (package
+ (name "emacs-org-msg")
+ (version "3.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jeremy-compostella/org-msg")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15gd5zbxvdallyra9lmpb9i1r2mmwz0j0i0ra7j9imnbfiz3ln9r"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-htmlize" ,emacs-htmlize)))
+ (home-page "https://github.com/jeremy-compostella/org-msg")
+ (synopsis "Mix Org mode and Message mode to compose emails")
+ (description
+ "OrgMsg is a GNU Emacs global minor mode mixing up Org mode and your
+Mail User Agent Mode (Message, mu4e, or Notmuch) to compose and reply to
+emails in a Outlook HTML friendly style.")
+ (license license:gpl3+))))
+
(define-public emacs-org-superstar
(package
(name "emacs-org-superstar")