summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-11-14 11:26:04 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-11-14 11:26:04 +0100
commit2980b726d3ec209c0cd00160588e2ea948c034ad (patch)
tree8825db3771f856c6e8768542c3e97cc357e99d79 /gnu/packages/emacs-xyz.scm
parente365f8b26c01d295e68dd0352a63cf274403f4fd (diff)
gnu: emacs-helm-system-packages: Update to 1.10.2.
* gnu/packages/emacs-xyz.scm (emacs-helm-system-packages): Update to 1.10.2.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm66
1 files changed, 31 insertions, 35 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 27042927ff..b53f460b88 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10712,46 +10712,42 @@ Yasnippet.")
(license license:gpl2+))))
(define-public emacs-helm-system-packages
- ;; There won't be a new release after 1.10.1 until
- ;; https://github.com/emacs-helm/helm-system-packages/issues/25 is fixed,
- ;; and latest commits fix import issues with Guix.
- (let ((commit "6572340f41611ef1991e9612d34d59130957ee4a"))
- (package
- (name "emacs-helm-system-packages")
- (version (git-version "1.10.1" "1" commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/emacs-helm/helm-system-packages")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0mcz6vkpk12vsyd37xv1rbg4v442sxc3lj8yxskqg294xbdaclz4"))))
- (build-system emacs-build-system)
- (inputs
- `(("recutils" ,recutils)))
- (propagated-inputs
- `(("emacs-helm" ,emacs-helm)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((recutils (assoc-ref inputs "recutils")))
- ;; Specify the absolute file names of the various
- ;; programs so that everything works out-of-the-box.
- (substitute* "helm-system-packages-guix.el"
- (("recsel") (string-append recutils "/bin/recsel")))))))))
- (home-page "https://github.com/emacs-helm/helm-system-packages")
- (synopsis "Helm System Packages is an interface to your package manager")
- (description "List all available packages in Helm (with installed
+ (package
+ (name "emacs-helm-system-packages")
+ (version "1.10.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-helm/helm-system-packages")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13a8jpj4wwm0yjv8hnsizgjf8wi3r2ap87lyvw7g4c7snp2dydwa"))))
+ (build-system emacs-build-system)
+ (inputs
+ `(("recutils" ,recutils)))
+ (propagated-inputs
+ `(("emacs-helm" ,emacs-helm)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((recutils (assoc-ref inputs "recutils")))
+ ;; Specify the absolute file names of the various
+ ;; programs so that everything works out-of-the-box.
+ (substitute* "helm-system-packages-guix.el"
+ (("recsel") (string-append recutils "/bin/recsel")))))))))
+ (home-page "https://github.com/emacs-helm/helm-system-packages")
+ (synopsis "Helm System Packages is an interface to your package manager")
+ (description "List all available packages in Helm (with installed
packages displayed in their own respective face). Fuzzy-search, mark and
execute the desired action over any selections of packages: Install,
uninstall, display packages details (in Org Mode) or insert details at point,
find files owned by packages... And much more, including performing all the
above over the network.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-helm-org-rifle
(package