summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorJens Mølgaard <jens@zete.tk>2019-07-18 19:55:46 +1200
committerLudovic Courtès <ludo@gnu.org>2019-07-27 01:00:03 +0200
commitd3f2f86a7f6acfa5459561253ae60e0fa0c3a957 (patch)
treeeac39cc080b52b13c65500ebe7d5e5a110013c78 /gnu/packages/emacs-xyz.scm
parent40c4c0058f64ee10db202560789f100cfceb4954 (diff)
gnu: Add emacs-wc-mode.
* gnu/packages/emacs-xyz.scm (emacs-wc-mode): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2315d0f3de..2f028a0dfc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16853,3 +16853,27 @@ zip utility (default is @code{zip}).")
(description "@code{ox-pandoc} is an exporter for converting Org-mode
files to numerous other formats via Pandoc.")
(license license:gpl3+)))
+
+(define-public emacs-wc-mode
+ (package
+ (name "emacs-wc-mode")
+ (version "1.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bnbeckwith/wc-mode.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pjlxv46zzqdq6q131jb306vqlg4sfqls1x8vag7mmfw462hafqp"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/bnbeckwith/wc-mode")
+ (synopsis "Running word count with goals (minor mode)")
+ (description "@code{wc-mode} is a minor mode, providing a ‘wc’ function
+for Emacs buffers as well as a modeline addition with live word, line and
+character counts. Additionally, a user can set specific goals for adding or
+deleting words. These goals were partly inspired by 750words.com where the
+goal of the site is to encourage writing by setting a goal of 750 words at a
+time.")
+ (license license:gpl3+)))