summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-17 22:11:28 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-17 22:12:26 +0100
commitee98b30a69caf0953cf352828c361533fc5d1d0b (patch)
tree15dab1d5dc3c9a64c660ee7d8bf7cdfade042df1 /gnu/packages/emacs-xyz.scm
parentb066c9b03da94d6b2d65ae3531ae24565622df29 (diff)
gnu: emacs-eldev: Update to 0.10.
* gnu/packages/emacs-xyz.scm (emacs-eldev): Update to 0.10. [arguments]: Enable some tests, disable some others. Remove #t at the end of phases.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm32
1 files changed, 15 insertions, 17 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5ee9f23385..89c86519da 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17631,16 +17631,16 @@ according to a parsing expression grammar.")
(define-public emacs-eldev
(package
(name "emacs-eldev")
- (version "0.9.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/doublep/eldev")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1jfj4f5w20qd12k6ygv0jazn2x9pxjrmqmlmibppc4ybrhhgmg0s"))))
+ (version "0.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/doublep/eldev")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1y1gc37vn8k1yhp6b069sg8hdh1bn22icdqn4b28c2k5iiw9g7gi"))))
(build-system emacs-build-system)
(arguments
`(#:tests? #t
@@ -17650,14 +17650,13 @@ according to a parsing expression grammar.")
(add-after 'unpack 'prepare-for-tests
(lambda _
(setenv "ELDEV_LOCAL" (getcwd))
- (make-file-writable
- "test/project-i/project-i-autoloads.el")
- #t))
+ (make-file-writable "test/project-i/project-i-autoloads.el")))
(add-after 'unpack 'skip-failing-tests
;; FIXME: 10 tests are failing. Skip them for now.
(lambda _
- (substitute* '("test/init.el" "test/targets.el")
- (("(targets-project-e-[34]|init-[1-8]).*" line)
+ (delete-file "test/upgrade-self.el")
+ (substitute* "test/init.el"
+ (("init-[1-8].*" line)
(string-append line "(skip-unless nil)\n")))))
(add-after 'install 'install-eldev-executable
;; This constructs the eldev executable from templates and
@@ -17674,8 +17673,7 @@ according to a parsing expression grammar.")
;; eldev doesn't try to bootstrap itself from MELPA when
;; invoked.
(("export ELDEV_EMACS.*" all)
- (string-append "export ELDEV_LOCAL=" site-lisp "\n" all)))
- #t))))))
+ (string-append "export ELDEV_LOCAL=" site-lisp "\n" all)))))))))
(native-inputs
`(("texinfo" ,texinfo))) ;for tests
(home-page "https://github.com/doublep/eldev/")