summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorIan Eure <ian@retrospec.tv>2023-11-14 18:13:16 -0800
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-11-23 09:29:04 +0100
commit1eafa4c4bee4c2f59820b439e8e0d442d2a41e37 (patch)
tree60e648fe50455358bc1434ac2af32b884d373b15 /gnu/packages/emacs-xyz.scm
parentbd59fca6d2ab472123fca7008366ea66a8a991eb (diff)
gnu: Add emacs-exwm-mff.
* gnu/packages/emacs-xyz.scm (emacs-exwm-mff): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5a2bbc58e7..828ccead0d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -31297,6 +31297,29 @@ generating a temp buffer in which any useful Emacs utilities and modes can be
invoked.")
(license license:gpl3+))))
+(define-public emacs-exwm-mff
+ (let ((commit "89206f2e3189f589c27c56bd2b6203e906ee7100")
+ (revision "1"))
+ (package
+ (name "emacs-exwm-mff")
+ (version (git-version "1.2.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/emacs-weirdware/exwm-mff.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ipmapyd4jmpnk34wk9kfbvqnl04x74yg2pmj298wqa61ylw1n9j"))))
+ (build-system emacs-build-system)
+ (home-page "https://codeberg.org/emacs-weirdware/exwm-mff")
+ (synopsis "Mouse follows focus for EXWM")
+ (description "This package provides a minor mode to automatically warp
+the mouse pointer to the center of a focused window, as well as a command to
+warp it to the currently selected window.")
+ (license (list license:gpl3+)))))
+
(define-public emacs-exwm-modeline
(package
(name "emacs-exwm-modeline")