summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorIan Eure <ian@retrospec.tv>2023-11-14 18:13:23 -0800
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-11-23 09:29:05 +0100
commit70140ba71967d0e6cf10d760bb22739b8696e6f2 (patch)
tree89c380a06a80c4c678d2c7564de4c3e733f6e041 /gnu/packages/emacs-xyz.scm
parent09ed237d624a341f8ca349f729f571536a81d1e4 (diff)
gnu: Add emacs-hyperspace.
* gnu/packages/emacs-xyz.scm (emacs-hyperspace): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4969dabb19..14039e8e3c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -36489,6 +36489,33 @@ to) the default-directory or – using projectile or find-file-in-project – a
project root.")
(license (list license:gpl3+)))))
+(define-public emacs-hyperspace
+ (let ((commit "f574d07fd8715e806ba4f0487b73c699963baed3")
+ (revision "1"))
+ (package
+ (name "emacs-hyperspace")
+ (version (git-version "0.8.5" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/emacs-weirdware/hyperspace.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19h3d12a99i7a92k3iw4zmjmw3dazsgnkc6j4965h033r1s40amx"))))
+ (build-system emacs-build-system)
+ (inputs (list emacs-s))
+ (home-page "https://codeberg.org/emacs-weirdware/hyperspace")
+ (synopsis "Get there from here")
+ (description
+ "Hyperspace is a way to get nearly anywhere from wherever
+you are, whether that's within Emacs or on the web. It's somewhere in between
+Quicksilver and keyword URLs, giving you a single, consistent interface to get
+directly where you want to go. It’s for things that you use often, but not
+often enough to justify a dedicated binding.")
+ (license (list license:gpl3+)))))
+
(define-public emacs-tshell
;; XXX: Upstream has no tagged release. Version is extracted from keyword
;; in main file.