summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-04-25 15:19:29 +0200
committerAndreas Enge <andreas@enge.fr>2023-04-25 15:19:29 +0200
commitc919bfefd98bf2e29549539b4e28e6dc2a8a6f32 (patch)
tree61d10f1fcc6f80d97f788e19df7f20ff7fc27752 /gnu/packages/emacs-xyz.scm
parentce0bdceb4948d5f297327a1b1724074ca960eb05 (diff)
parent472706ae2f9160833951a4e4bcc4c206e03097b0 (diff)
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm125
1 files changed, 75 insertions, 50 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index da81720312..7c8af093fc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3715,14 +3715,14 @@ as a library for other Emacs packages.")
(define-public emacs-auctex
(package
(name "emacs-auctex")
- (version "13.1.10")
+ (version "13.2.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"auctex-" version ".tar"))
(sha256
- (base32 "0vxf3aw7j73d0cbfh8d5fp5gyi7vxq9vb7fqxmxxs24pvdnlym15"))))
+ (base32 "1jk05cca7lrwykj3by4s7c198bffam0mga7hgwmcz5bgxl79ijvf"))))
(build-system emacs-build-system)
;; We use 'emacs' because AUCTeX requires dbus at compile time
;; ('emacs-minimal' does not provide dbus).
@@ -17700,14 +17700,14 @@ the center of the screen and not at the bottom.")
(define-public emacs-posframe
(package
(name "emacs-posframe")
- (version "1.4.1")
+ (version "1.4.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"posframe-" version ".tar"))
(sha256
- (base32 "02kw3d6760015q61sryw8k3zqdnzhcwwyfjfysbfs07cljkqpjnh"))))
+ (base32 "0ca43wgbr0n5ri7cyxjmn7blq59xq43rx9z9q02a2j4yn05w8nss"))))
(build-system emacs-build-system)
;; emacs-minimal does not include the function font-info.
(arguments
@@ -20964,50 +20964,50 @@ close, copy, cut, paste, undo, redo.")
(license license:gpl3+)))
(define-public emacs-password-store
- (let ((commit "918992c19231b33b3d4a3288a7288a620e608cb4")
- (revision "1"))
- (package
- (name "emacs-password-store")
- ;; The emacs package version does not match the password-store version,
- ;; even though it is part of the same repository. When updating, look
- ;; at the version declared in password-store.el.
- (version (git-version "2.1.4" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "git://git.zx2c4.com/password-store")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0ni62f4pq96g0i0q66bch1dl9k4zqwhg7xaf746k3gbbqxcdh3vi"))))
- (build-system emacs-build-system)
- (arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'extract-el-file
- (lambda _
- (copy-file "contrib/emacs/password-store.el"
- "password-store.el")
- (delete-file-recursively "contrib")
- (delete-file-recursively "man")
- (delete-file-recursively "src")
- (delete-file-recursively "tests")))
- (add-after 'extract-el-file 'patch-executables
- (lambda* (#:key inputs #:allow-other-keys)
- (emacs-substitute-variables "password-store.el"
- ("password-store-executable"
- (search-input-file inputs "/bin/pass"))))))))
- (inputs
- (list password-store))
- (propagated-inputs
- (list emacs-auth-source-pass emacs-s emacs-with-editor))
- (home-page "https://git.zx2c4.com/password-store/tree/contrib/emacs")
- (synopsis "Password store (pass) support for Emacs")
- (description
- "This package provides functions for working with pass (\"the
-standard Unix password manager\").")
- (license license:gpl3+))))
+ (package
+ (name "emacs-password-store")
+ ;; The emacs package version does not match the password-store version,
+ ;; even though it is part of the same repository. When updating, look at
+ ;; the version declared in password-store.el.
+ (version "2.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://git.zx2c4.com/password-store")
+ (commit "26d2dae04bb76a87be6960861c10432820cd5d55")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pkx6pgkkpddxrshzq3x8ilfwqjw9gawnbbskcbssxc88wrpbcjb"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'extract-el-file
+ (lambda _
+ (copy-file "contrib/emacs/password-store.el"
+ "password-store.el")
+ (delete-file-recursively "contrib")
+ (delete-file-recursively "man")
+ (delete-file-recursively "src")
+ (delete-file-recursively "tests")))
+ (add-after 'extract-el-file 'patch-executables
+ (lambda* (#:key inputs #:allow-other-keys)
+ (emacs-substitute-variables "password-store.el"
+ ("password-store-executable"
+ (search-input-file inputs "/bin/pass"))))))))
+ (inputs
+ (list password-store))
+ (propagated-inputs
+ (list emacs-s emacs-with-editor))
+ (home-page "https://git.zx2c4.com/password-store/tree/contrib/emacs")
+ (synopsis "Password store (pass) support for Emacs")
+ (description
+ "This package provides functions for working with pass (\"the
+ standard Unix password manager\").")
+ (license license:gpl3+)))
(define-public emacs-password-store-otp
(package
@@ -24950,7 +24950,7 @@ appropriate directory if no @code{eshell} session is active.")
(define-public emacs-eshell-syntax-highlighting
(package
(name "emacs-eshell-syntax-highlighting")
- (version "0.4")
+ (version "0.5")
(source
(origin
(method git-fetch)
@@ -24959,7 +24959,7 @@ appropriate directory if no @code{eshell} session is active.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1ib46fs70grx7rmw45i817v1dyvcj0b8xdmndvaz7papiimf6vrj"))))
+ (base32 "1la604vdj56s934j16yz8rlvzhd69433rrbgfyw9c7njxqldwcs7"))))
(build-system emacs-build-system)
(home-page "https://github.com/akreisher/eshell-syntax-highlighting")
(synopsis "Add syntax highlighting to Eshell")
@@ -35141,6 +35141,31 @@ the TypeScript implementation.")
service.")
(license license:expat))))
+(define-public emacs-xonsh-mode
+ ;; There is no tagged release yet.
+ (let ((commit "7fa581524533a9b6b770426e4445e571a69e469d")
+ (revision "0"))
+ (package
+ (name "emacs-xonsh-mode")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/seanfarley/xonsh-mode")
+ (commit commit)))
+ (sha256
+ (base32 "0lfi2372clkkzi4a940fwparsfhxxzb7bmysfd50n1myakgldri5"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/seanfarley/xonsh-mode")
+ (synopsis "Emacs major mode for editing Xonsh files")
+ (description
+ "This package implements a major mode for Xonsh scripts. The basic
+functionality includes syntax highlight for Xonsh operators. Files with the
+@file{.xonshrc} or @file{.xsh} extension are automatically opened with this
+mode.")
+ (license license:gpl3+))))
+
(define-public emacs-monokai-theme
(package
(name "emacs-monokai-theme")