summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-22 20:12:52 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-22 20:12:52 +0200
commit119a749db9c9847e0766860c17109b0f0b6bf349 (patch)
tree4cdbfcad285124c1abf7b3c1c94666cef55767ce /gnu/packages/emacs.scm
parent530d9e1555e8d0125dde6893f5f70c7a1ebc2564 (diff)
parent25669275a1a570cc266128274cb27a22f6a3a318 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 315db18a57..bc803892af 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -135,7 +135,17 @@
(format #f "(tramp-default-remote-path ~s ~s ~s ~s "
"~/.guix-profile/bin" "~/.guix-profile/sbin"
"/run/current-system/profile/bin"
- "/run/current-system/profile/sbin")))))))
+ "/run/current-system/profile/sbin")))
+
+ ;; Make sure Man looks for C header files in the right
+ ;; places.
+ (substitute* "man.el"
+ (("\"/usr/local/include\"" line)
+ (string-join
+ (list line
+ "\"~/.guix-profile/include\""
+ "\"/var/guix/profiles/system/profile/include\"")
+ " ")))))))
(build-system glib-or-gtk-build-system)
(arguments
`(#:phases
@@ -5657,6 +5667,26 @@ pair of minor modes which suppress all mouse events by intercepting them and
running a customisable handler command (@code{ignore} by default). ")
(license license:gpl3+)))
+(define-public emacs-json-snatcher
+ (package
+ (name "emacs-json-snatcher")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Sterlingg/json-snatcher/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1nfiwsifpdiz0lbrqa77nl0crnfrv5h85ans9b0g5rggnmyshcfb"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/sterlingg/json-snatcher")
+ (synopsis "Grabs the path to JSON values in a JSON file")
+ (description "@code{emacs-json-snatcher} grabs the path to JSON values in
+a @url{http://json.org/, JSON} file.")
+ (license license:gpl3+)))
+
(define-public emacs-restclient
(let ((commit "07a3888bb36d0e29608142ebe743b4362b800f40")
(revision "1")) ;Guix package revision,