summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-17 10:06:05 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-18 22:10:58 -0500
commit90b1fe57d0fb2f06dd578813c720902a5b2363bc (patch)
tree96a0d0b317db05169672caddca7f7a9b106e7781 /gnu/packages/emacs.scm
parentd97a6c9ba7ed4085299dc4a734d1ad14e215d3a1 (diff)
gnu: emacs: Patch awk, find, sed and sh commands.
Before this change, using Emacs in a pure environment, e.g. 'guix shell --pure emacs', would cause problems such as: jka-compr-insert-file-contents: Uncompression program ‘sh’ not found And other problems were found requiring the other tools. * gnu/packages/emacs.scm (emacs-minimal) [arguments]: Extend the patch-program-file-names phase. [inputs]: Add findutils, gawk and sed. Series-changes: 2 - Patch references in place instead of wrapping via PATH Change-Id: Ifb4fe2fc12ddc9eae387adb3da3f7821fab78e65
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm56
1 files changed, 52 insertions, 4 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b9d9e2b891..3e8de3c2e0 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2016 David Thompson <dthompson2@worcester.edu>
;;; Copyright © 2016 Nikita <nikita@n0.is>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2017, 2019, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2017, 2019, 2020, 2023, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
@@ -59,6 +59,7 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages fribidi)
+ #:use-module (gnu packages gawk)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gd)
#:use-module (gnu packages gettext)
@@ -157,13 +158,60 @@
(delete-file "configure"))))
(add-after 'unpack 'patch-program-file-names
(lambda* (#:key inputs #:allow-other-keys)
+ ;; Substitute "sh" command.
(substitute* '("src/callproc.c"
"lisp/term.el"
"lisp/htmlfontify.el"
+ "lisp/mail/feedmail.el"
+ "lisp/obsolete/pgg-pgp.el"
+ "lisp/obsolete/pgg-pgp5.el"
+ "lisp/obsolete/terminal.el"
+ "lisp/org/ob-eval.el"
"lisp/textmodes/artist.el"
- "lisp/progmodes/sh-script.el")
+ "lisp/progmodes/sh-script.el"
+ "lisp/textmodes/artist.el"
+ "lisp/htmlfontify.el"
+ "lisp/term.el")
(("\"/bin/sh\"")
- (format #f "~s" (search-input-file inputs "/bin/sh"))))
+ (format #f "~s" (search-input-file inputs "bin/sh"))))
+ (substitute* '("lisp/gnus/mm-uu.el"
+ "lisp/gnus/nnrss.el"
+ "lisp/mail/blessmail.el")
+ (("\"#!/bin/sh\\\n\"")
+ (format #f "\"#!~a~%\"" (search-input-file inputs "bin/sh"))))
+ (substitute* '("lisp/jka-compr.el"
+ "lisp/man.el")
+ (("\"sh\"")
+ (format #f "~s" (search-input-file inputs "bin/sh"))))
+
+ ;; Substitute "awk" command.
+ (substitute* '("lisp/gnus/nnspool.el"
+ "lisp/org/ob-awk.el"
+ "lisp/man.el")
+ (("\"awk\"")
+ (format #f "~s" (search-input-file inputs "bin/awk"))))
+
+ ;; Substitute "find" command.
+ (substitute* '("lisp/gnus/gnus-search.el"
+ "lisp/obsolete/nnir.el"
+ "lisp/progmodes/executable.el"
+ "lisp/progmodes/grep.el"
+ "lisp/filecache.el"
+ "lisp/ldefs-boot.el"
+ "lisp/mpc.el")
+ (("\"find\"")
+ (format #f "~s" (search-input-file inputs "bin/find"))))
+
+ ;; Substitute "sed" command.
+ (substitute* "lisp/org/ob-sed.el"
+ (("org-babel-sed-command \"sed\"")
+ (format #f "org-babel-sed-command ~s"
+ (search-input-file inputs "bin/sed"))))
+ (substitute* "lisp/man.el"
+ (("Man-sed-command \"sed\"")
+ (format #f "Man-sed-command ~s"
+ (search-input-file inputs "bin/sed"))))
+
(substitute* "lisp/doc-view.el"
(("\"(gs|dvipdf|ps2pdf|pdftotext)\"" all what)
(let ((replacement (false-if-exception
@@ -254,7 +302,7 @@
(copy-file
(car (find-files "bin" "^emacs-([0-9]+\\.)+[0-9]+$"))
"bin/emacs")))))))
- (inputs (list bash-minimal coreutils gzip ncurses))
+ (inputs (list bash-minimal coreutils findutils gawk gzip ncurses sed))
(native-inputs (list autoconf pkg-config texinfo))
(home-page "https://www.gnu.org/software/emacs/")
(synopsis "The extensible text editor (minimal build for byte-compilation)")