summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2016-05-31 16:30:44 -0400
committerDavid Thompson <davet@gnu.org>2016-06-03 08:54:25 -0400
commit65b49ae702e4da3826355cb2f6c58eab97c15cbb (patch)
treeefeb3ffff33ddfd59a57933a62b0ff955f27381b /gnu/packages/emacs.scm
parentc86f0207cee9da871c05920b243f92ae369f8505 (diff)
gnu: Add emacs-ido-completing-read+.
* gnu/packages/emacs.scm (emacs-ido-completing-read+): New variable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 54885f4047..ee875eff27 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1931,3 +1931,26 @@ successive level is highlighted in a different color, making it easy to spot
matching delimiters, orient yourself in the code, and tell which statements
are at a given level.")
(license license:gpl3+)))
+
+(define-public emacs-ido-completing-read+
+ (package
+ (name "emacs-ido-completing-read+")
+ (version "3.12")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://raw.githubusercontent.com"
+ "/DarwinAwardWinner/ido-ubiquitous/v"
+ version "/ido-completing-read+.el"))
+ (file-name (string-append "ido-completing-read+-" version ".el"))
+ (sha256
+ (base32
+ "1cyalb0p7nfsm4n6n9q6rjmvn6adqc0fq8ybnlj3n41n289dkfjf"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/DarwinAwardWinner/ido-ubiquitous")
+ (synopsis "Replacement for completing-read using ido")
+ (description
+ "The ido-completing-read+ function is a wrapper for ido-completing-read.
+Importantly, it detects edge cases that ordinary ido cannot handle and either
+adjusts them so ido can handle them, or else simply falls back to the standard
+Emacs completion function instead.")
+ (license license:gpl3+)))