summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-06-30 22:35:12 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-07-01 19:43:17 +0300
commit960231873661365bb6228d62c5452e634d6da5d2 (patch)
tree1cf523d03454a73d7b482797f3233475d33e491c /gnu/packages/emacs.scm
parent545ceac801404f7ff3501b9f47cdc4e383592656 (diff)
gnu: emacs-browse-at-remote: Update to 0.10.0.
* gnu/packages/emacs.scm (emacs-browse-at-remote): Update to 0.10.0. * gnu/packages/patches/emacs-browse-at-remote-cgit-gnu.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm58
1 files changed, 27 insertions, 31 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 349ae0d20c..c4468c8175 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -7027,39 +7027,35 @@ Idris.")
(license license:gpl3+)))
(define-public emacs-browse-at-remote
- (let ((commit "31dcf77d7c89a12f230e2b2332585db2c44530ef")
- (revision "1"))
- (package
- (name "emacs-browse-at-remote")
- (version (string-append "0.9.0-" revision "."
- (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/rmuslimov/browse-at-remote.git")
- (commit commit)))
- (file-name (string-append name "-" version "-checkout"))
- (patches
- (search-patches "emacs-browse-at-remote-cgit-gnu.patch"))
- (sha256
- (base32
- "017cb8lf7zbg0jmr7zxzd7d5kz2jy35cvw5vcpdmq1fdr3wqwkgj"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-f" ,emacs-f)
- ("emacs-s" ,emacs-s)))
- (native-inputs
- `(("ert-runner" ,ert-runner)))
- (arguments
- `(#:tests? #t
- #:test-command '("ert-runner")))
- (home-page "https://github.com/rmuslimov/browse-at-remote")
- (synopsis "Open github/gitlab/bitbucket/stash page from Emacs")
- (description
- "This Emacs package allows you to open a target page on
+ (package
+ (name "emacs-browse-at-remote")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/rmuslimov/browse-at-remote/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ymslsp6i1naw25zckv25bf4aaq6qwkbkn95qyzlwg869l802686"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-f" ,emacs-f)
+ ("emacs-s" ,emacs-s)))
+ (native-inputs
+ `(("ert-runner" ,ert-runner)))
+ (arguments
+ `(#:tests? #t
+ #:test-command '("ert-runner")))
+ (home-page "https://github.com/rmuslimov/browse-at-remote")
+ (synopsis "Open github/gitlab/bitbucket/stash page from Emacs")
+ (description
+ "This Emacs package allows you to open a target page on
github/gitlab (or bitbucket) by calling @code{browse-at-remote} command.
It supports dired buffers and opens them in tree mode at destination.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-tiny
(package