summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorMatthew Jordan <matthewjordandevops@yandex.com>2016-05-18 17:39:45 -0400
committerAlex Kost <alezost@gmail.com>2016-06-04 15:45:32 +0300
commitae60900199d8b19155a3ccf52a957148e974454c (patch)
treebf9c76b8663bb6188cd7aa14644c98b6e01a795a /gnu/packages/emacs.scm
parenta88825d9653cab7ba4620f8ccec84e12810f1b4b (diff)
gnu: Add emacs-helm.
* gnu/packages/emacs.scm (emacs-helm): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 0ce34b9001..797041f05d 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2016 humanitiesNerd <catonano@gmail.com>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
+;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2023,3 +2024,32 @@ Velocity, Cheetah, Smarty, CTemplate, Mustache, Blade, ErlyDTL, Go Template,
Dust.js, React/JSX, Angularjs, ejs, etc.")
(home-page "http://web-mode.org/")
(license license:gpl3+)))
+
+(define-public emacs-helm
+ (package
+ (name "emacs-helm")
+ (version "1.9.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/" name "/helm/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0fc897rwf1fm2m7jrsikkgcyzhngfcysxfmzchpwzfj6v9sb5rl9"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-async" ,emacs-async)
+ ("emacs-popup" ,emacs-popup)))
+ (home-page "https://emacs-helm.github.io/helm/")
+ (synopsis "Incremental completion and selection narrowing
+framework for Emacs")
+ (description "Helm is incremental completion and selection narrowing
+framework for Emacs. It will help steer you in the right direction when
+you're looking for stuff in Emacs (like buffers, files, etc). Helm is a fork
+of @code{anything.el} originally written by Tamas Patrovic and can be
+considered to be its successor. Helm sets out to clean up the legacy code in
+@code{anything.el} and provide a cleaner, leaner and more modular tool, that's
+not tied in the trap of backward compatibility.")
+ (license license:gpl3+)))