summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2017-01-15 21:10:50 +0000
committerAlex Kost <alezost@gmail.com>2017-01-18 12:57:23 +0300
commit899bcad310291ebbad5af02cb07bdf8d9e9a25f1 (patch)
tree5d71fbe8db269d072c342fced54d650b382afb2b /gnu/packages/emacs.scm
parentcf006d2e738f473e7fb630b566e04c4872fa204b (diff)
gnu: Add emacs-sx.
* gnu/packages/emacs.scm (emacs-sx): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index e11039a8a5..e44dae784d 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Alex Vong <alexvong1995@gmail.com>
@@ -1431,6 +1431,29 @@ allows easily move between them.")
strings.")
(license license:gpl3+)))
+(define-public emacs-sx
+ (package
+ (name "emacs-sx")
+ (version "0.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/vermiculus/sx.el/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1w0xghfljqg31axcnv8gzlrd8pw25nji6idnrhflq0af9qh1dw03"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-markdown-mode" ,emacs-markdown-mode)
+ ("let-alist" ,let-alist)))
+ (home-page "https://github.com/vermiculus/sx.el/")
+ (synopsis "Emacs StackExchange client")
+ (description
+ "Emacs StackExchange client. Ask and answer questions on
+Stack Overflow, Super User, and other StackExchange sites.")
+ (license license:gpl3+)))
+
(define-public emacs-f
(package
(name "emacs-f")