summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorDmitry Bogatov <KAction@gnu.org>2015-12-30 21:06:49 +0300
committerLudovic Courtès <ludo@gnu.org>2016-01-05 00:28:42 +0100
commit1075b43737825e3eea24e31ad02142c45747d4bb (patch)
tree995fa569f8afa11a78b4405108e95f73c43a1dd7 /gnu/packages/emacs.scm
parentfe542b97621db472f2a7698712e65b92fd30d005 (diff)
gnu: Add emacs-undo-tree.
* gnu/packages/emacs.scm (emacs-undo-tree): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 1529f6a6b7..e82ffd33a7 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1013,6 +1013,27 @@ and stored in memory.")
(description "This package provides a modern list API library for Emacs.")
(license license:gpl3+)))
+(define-public emacs-undo-tree
+ (package
+ (name "emacs-undo-tree")
+ (version "0.6.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "http://dr-qubit.org/git/undo-tree.git")
+ (commit "release/0.6.4")))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0b6hnv6bq1g5np5q2yw9r9aj1cxpp14akm21br7vpb7wp01fv4b3"))))
+ (build-system emacs-build-system)
+ (home-page "http://www.dr-qubit.org/emacs.php")
+ (synopsis "Treat undo history as a tree")
+ (description "Tree-like interface to Emacs undo system, providing
+graphical tree presentation of all previous states of buffer that
+allows easily move between them.")
+ (license license:gpl3+)))
+
(define-public emacs-s
(package
(name "emacs-s")