summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-17 11:15:23 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-17 11:21:42 +0200
commit2d1db448bdbce9cd8a6df39097f56c3840754949 (patch)
tree81408dc9b6fd7074d6b015882c6816b9e8db927d /gnu/packages/emacs.scm
parentd001bb5ab54b4e174392be6137e7acaec1e6f0f3 (diff)
gnu: Add emacs-typo.
* gnu/packages/emacs.scm (typo): New variable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index cdd73206c4..a342f4861b 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1148,3 +1148,27 @@ integration servers. Users can specify a list of server in the
view the build status of those servers' build jobs, and possibly to trigger
build jobs.")
(license license:gpl3+)))
+
+(define-public typo
+ (package
+ (name "emacs-typo")
+ (version "1.1")
+ (home-page "https://github.com/jorgenschaefer/typoel")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1jhd4grch5iz12gyxwfbsgh4dmz5hj4bg4gnvphccg8dsnni05k2"))
+ (file-name (string-append name "-" version))))
+ (build-system emacs-build-system)
+ (synopsis "Minor mode for typographic editing")
+ (description
+ "This package provides two Emacs modes, @code{typo-mode} and
+@code{typo-global-mode}. These modes automatically insert Unicode characters
+for quotation marks, dashes, and ellipses. For example, typing @kbd{\"}
+automatically inserts a Unicode opening or closing quotation mark, depending
+on context.")
+ (license license:gpl3+)))