summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-13 21:28:01 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-13 21:28:01 +0200
commit75710da66710cef1d32053cd8f350d13057d02a7 (patch)
treeabef6a326c741b1eb18db866b2f2bacee3e5fc51 /gnu/packages/emacs.scm
parentab20c2cc33063ce783515d8ae7899ec7e2ca6f96 (diff)
parent610075f7c94c80b8321887b7ccf8bb1a7edd2b8e (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm107
1 files changed, 105 insertions, 2 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 9c7a19ad59..b6ca6cfc66 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -310,7 +310,7 @@ configuration files, such as .gitattributes, .gitignore, and .git/config.")
(define-public magit
(package
(name "magit")
- (version "2.2.1")
+ (version "2.2.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -318,7 +318,7 @@ configuration files, such as .gitattributes, .gitignore, and .git/config.")
version "/" name "-" version ".tar.gz"))
(sha256
(base32
- "0bjdj4468i5w3j2i945b6psb6n04z34vhjaqr0iz4xgixk3wiqmh"))))
+ "1imkj4prprnivhbpdn1mdpiryxkckzy5hbnqaahv7gixwac1irh8"))))
(build-system gnu-build-system)
(native-inputs `(("texinfo" ,texinfo)
("emacs" ,emacs-no-x)))
@@ -483,6 +483,82 @@ support for Git-SVN.")
programs.")
(license license:gpl3+)))
+(define-public let-alist
+ (package
+ (name "emacs-let-alist")
+ (version "1.0.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://elpa.gnu.org/packages/let-alist-"
+ version ".el"))
+ (sha256
+ (base32
+ "07312bvvyz86lf64vdkxg2l1wgfjl25ljdjwlf1bdzj01c4hm88x"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils)
+ (guix build emacs-utils))
+
+ #:builder (begin
+ (use-modules (guix build emacs-utils)
+ (guix build utils))
+
+ (let* ((out (assoc-ref %outputs "out"))
+ (lispdir (string-append out
+ "/share/emacs/site-lisp/"
+ "guix.d/let-alist-"
+ ,version))
+ (emacs (assoc-ref %build-inputs "emacs")))
+
+ (mkdir-p lispdir)
+ (copy-file (assoc-ref %build-inputs "source")
+ (string-append lispdir "/let-alist.el"))
+
+ (setenv "PATH" (string-append emacs "/bin"))
+ (emacs-byte-compile-directory lispdir)
+ #t))))
+ (native-inputs `(("emacs" ,emacs-no-x)))
+ (home-page "http://elpa.gnu.org/packages/let-alist.html")
+ (synopsis "Easily let-bind values of an assoc-list by their names")
+ (description
+ "This package offers a single Emacs Lisp macro, @code{let-alist}. This
+macro takes a first argument, whose value must be an alist (association list),
+and a body.
+
+The macro expands to a let form containing the body, where each dotted symbol
+inside body is let-bound to their cdrs in the alist. Only those present in
+the body are let-bound and this search is done at compile time.")
+ (license license:gpl3+)))
+
+(define-public flycheck
+ (package
+ (name "emacs-flycheck")
+ (version "0.23")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/flycheck/flycheck/releases/download/"
+ version "/flycheck-" version ".tar"))
+ (sha256
+ (base32
+ "1n2cifzsl5dbv42l82bi3y1vk6q33msi8dd4bj7b9nvnl9jfjj5b"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-let-alist" ,let-alist)))
+ (home-page "https://www.flycheck.org")
+ (synopsis "On-the-fly syntax checking")
+ (description
+ "This package provides on-the-fly syntax checking for GNU Emacs. It is a
+replacement for the older Flymake extension which is part of GNU Emacs, with
+many improvements and additional features.
+
+Flycheck provides fully-automatic, fail-safe, on-the-fly background syntax
+checking for over 30 programming and markup languages with more than 70
+different tools. It highlights errors and warnings inline in the buffer, and
+provides an optional IDE-like error list.")
+ (license license:gpl3+))) ;+GFDLv1.3+ for the manual
+
;;;
;;; Web browsing.
@@ -989,3 +1065,30 @@ files and directories.")
(description "This package adds support to Org-Babel for evaluating Python
source code using IPython.")
(license license:gpl3+)))
+
+(define-public emacs-debbugs
+ (package
+ (name "emacs-debbugs")
+ (version "0.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://elpa.gnu.org/packages/debbugs-"
+ version ".tar"))
+ (sha256
+ (base32
+ "0pbglx3paa8icazgxlg4jf40wl8war63y9j2jmbb7gbd1xp95v72"))))
+ (build-system emacs-build-system)
+ (home-page "http://elpa.gnu.org/packages/debbugs.html")
+ (synopsis "Access the Debbugs bug tracker in Emacs")
+ (description
+ "This package lets you access the @uref{http://bugs.gnu.org,GNU Bug
+Tracker} from within Emacs.
+
+For instance, it defines the command @code{M-x debbugs-gnu} for listing bugs,
+and the command @code{M-x debbugs-gnu-search} for bug searching. If you
+prefer the listing of bugs as TODO items of @code{org-mode}, you could use
+@code{M-x debbugs-org} and related commands.
+
+A minor mode @code{debbugs-browse-mode} let you browse URLs to the GNU Bug
+Tracker as well as bug identifiers prepared for @code{bug-reference-mode}.")
+ (license license:gpl3+)))