summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2016-07-28 11:08:55 +0200
committerAndreas Enge <andreas@enge.fr>2016-07-28 11:08:55 +0200
commite309c7561043361afe63cc9435e620323f870a61 (patch)
treecd6fe073ba840bb68f446933ece44b45d8eb5ec7 /gnu/packages/emacs.scm
parent1bb163b0dd07c8f2cfd7e91f1e428075cd3d5ed2 (diff)
parente335b82c4eba13fe873db2d680d399469931c10f (diff)
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 5a718fa341..fb19c87bca 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -446,7 +447,9 @@ on stdout instead of using a socket as the Emacsclient does.")
(build-system gnu-build-system)
(native-inputs `(("texinfo" ,texinfo)
("emacs" ,emacs-minimal)))
- (inputs `(("git" ,git)))
+ (inputs
+ `(("git" ,git)
+ ("perl" ,perl)))
(propagated-inputs
`(("dash" ,emacs-dash)
("with-editor" ,emacs-with-editor)))
@@ -479,9 +482,12 @@ on stdout instead of using a socket as the Emacsclient does.")
(add-before
'build 'patch-exec-paths
(lambda* (#:key inputs #:allow-other-keys)
- (let ((git (assoc-ref inputs "git")))
+ (let ((git (assoc-ref inputs "git"))
+ (perl (assoc-ref inputs "perl")))
(emacs-substitute-variables "lisp/magit-git.el"
("magit-git-executable" (string-append git "/bin/git")))
+ (substitute* "lisp/magit-sequence.el"
+ (("perl") (string-append perl "/bin/perl")))
#t))))))
(home-page "http://magit.github.io/")
(synopsis "Emacs interface for the Git version control system")