summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2016-12-30 20:29:27 +0000
committerLeo Famulari <leo@famulari.name>2017-01-03 22:46:55 -0500
commit0916dc526e77f61d19895c9951c8d47d15c4941d (patch)
treed3474416ef9934ba28836fa442ce44c58997b665 /gnu/packages/emacs.scm
parentea5cc29561d0b1e343170607969cce884b3ddf14 (diff)
gnu: Add emacs-git-gutter
* gnu/packages/emacs.scm (emacs-git-gutter): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 5b6b9900ae..f062a7557a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1414,6 +1414,32 @@ strings.")
files and directories.")
(license license:gpl3+)))
+(define-public emacs-git-gutter
+ (package
+ (name "emacs-git-gutter")
+ (version "0.90")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/syohex/" name "/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1nmhvhpq1l56mj2yq3ag23rw3x4xgnsy8szp30s26l0yjnkhc4qg"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/syohex/emacs-git-gutter")
+ (synopsis "See and manage hunks of text in a version control system")
+ (description
+ "This package is an Emacs minor mode for displaying and interacting with
+hunks of text managed in a version control system. Added modified and deleted
+areas can be indicated with symbols on the edge of the buffer, and commands
+can be used to move between and perform actions on these hunks.
+
+Git, Mercurial, Subversion and Bazaar are supported, and many parts of the
+display and behaviour is easily customisable.")
+ (license license:gpl3+)))
+
(define-public emacs-el-mock
(package
(name "emacs-el-mock")