summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2016-05-31 13:52:30 -0400
committerDavid Thompson <davet@gnu.org>2016-06-03 08:54:25 -0400
commit3e5be84b69c859677620cb3311ed7427d88735a7 (patch)
tree191c0a053e0ad3f151b046752433c5b9920ee969 /gnu/packages/emacs.scm
parentc5c08f1b1ea1a2adde4f746209cdea0e8696c4e3 (diff)
gnu: Add emacs-js2-mode.
* gnu/packages/emacs.scm (emacs-js2-mode): New variable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 71f2f8b531..cad843c41e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1817,3 +1817,26 @@ agree upon.")
convenient interface to your recently and most frequently used commands. And
to all the other commands, too.")
(license license:gpl3+)))
+
+(define-public emacs-js2-mode
+ (package
+ (name "emacs-js2-mode")
+ (version "20150909")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mooz/js2-mode/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1nsm36c4kwb473p13i58fgrnlk8fbn3rdhj47d9xz70az4ra44q0"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/mooz/js2-mode/")
+ (synopsis "Improved JavaScript editing mode for Emacs")
+ (description
+ "Js2-mode provides a JavaScript major mode for Emacs that is more
+advanced than the built-in javascript-mode. Features include accurate syntax
+highlighting using a recursive-descent parser, on-the-fly reporting of syntax
+errors and strict-mode warnings, smart line-wrapping within comments and
+strings, and code folding.")
+ (license license:gpl3+)))