summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-10-17 16:47:12 -0400
committerMark H Weaver <mhw@netris.org>2016-10-17 16:47:12 -0400
commitdcaf70897a0bad38a4638a2905aaa3c46b1f1402 (patch)
tree439c42bf27972a628ebc0fef11a63b9130ca19a5 /gnu/packages/emacs.scm
parentbf62b8ff79f9d60136996b8251b6475965cf4994 (diff)
parent040b6299d505c034b4960c335434a500ae2f8187 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm71
1 files changed, 70 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 1b345dba1f..6e9c181b21 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2016 ng0 <ngillmann@runbox.com>
+;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Alex Vong <alexvong1995@gmail.com>
@@ -2981,6 +2981,54 @@ Lua programing language}.")
news items, openrc and runscripts.")
(license license:gpl2+)))
+(define-public emacs-evil
+ (package
+ (name "emacs-evil")
+ (version "1.2.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://bitbucket.org/lyro/evil/get/"
+ version ".tar.bz2"))
+ (file-name (string-append name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "17cda9fnbq3gmjcxs3lyq64gxswrf37y864bm53rldwsk3khq2yi"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-undo-tree" ,emacs-undo-tree)
+ ("emacs-goto-chg" ,emacs-goto-chg)))
+ (home-page "https://bitbucket.com/lyro/evil")
+ (synopsis "Extensible Vi layer for Emacs")
+ (description
+ "Evil is an extensible vi layer for Emacs. It emulates the
+main features of Vim, and provides facilities for writing custom
+extensions.")
+ (license license:gpl3+)))
+
+(define-public emacs-goto-chg
+ (package
+ (name "emacs-goto-chg")
+ (version "1.6")
+ (source
+ (origin
+ (method url-fetch)
+ ;; There is no versioned source.
+ (uri "https://www.emacswiki.org/emacs/download/goto-chg.el")
+ (sha256
+ (base32
+ "078d6p4br5vips7b9x4v6cy0wxf6m5ij9gpqd4g33bryn22gnpij"))))
+ (build-system emacs-build-system)
+ ;; There is no other home page.
+ (home-page "https://www.emacswiki.org/emacs/goto-chg.el")
+ (synopsis "Go to the last change in the Emacs buffer")
+ (description
+ "This package provides @code{M-x goto-last-change} command that goes to
+the point of the most recent edit in the current Emacs buffer. When repeated,
+go to the second most recent edit, etc. Negative argument, @kbd{C-u -}, is
+used for reverse direction.")
+ (license license:gpl2+)))
+
(define-public emacs-writegood-mode
(package
(name "emacs-writegood-mode")
@@ -3183,3 +3231,24 @@ display and edit the text.
This package contains the library runtime.")
(license license:lgpl2.1+)))
+
+(define-public emacs-nginx-mode
+ (package
+ (name "emacs-nginx-mode")
+ (version "1.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/ajc/nginx-mode/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1lvkj07kq0jkskr2f61vqb5rlrbnaz9a76ikq40w6925i2r970rr"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/ajc/nginx-mode")
+ (synopsis "Emacs major mode for editing nginx config files")
+ (description "This package provides an Emacs major mode for
+editing nginx config files.")
+ (license license:gpl2+)))