summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2016-08-25 13:49:31 +0800
committerAlex Kost <alezost@gmail.com>2016-08-26 10:48:36 +0300
commite7761186c3aacd36ae522e86e961d4f954be8794 (patch)
tree8e79f9d8242dede7ac3215cf7bd757b08e5ed2c4 /gnu/packages/emacs.scm
parentad5d899eff2a02c3f7a0ec4d2d25e8796888df5b (diff)
gnu: Add emacs-ahungry-theme.
* gnu/packages/emacs.scm (emacs-ahungry-theme): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c0ac67aa60..4fe9a8aae6 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2016 Alex Vong <alexvong1995@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2092,6 +2093,26 @@ It is built on top of the custom theme support in Emacs 24 or later.")
package provides a light and a dark variant.")
(license license:gpl3+)))
+(define-public emacs-ahungry-theme
+ (package
+ (name "emacs-ahungry-theme")
+ (version "1.3.0")
+ (source
+ (origin (method url-fetch)
+ (uri (string-append "http://elpa.gnu.org/packages/ahungry-theme-"
+ version ".tar"))
+ (sha256
+ (base32
+ "1p2zaq0s4bbl5cx6wyab24wamw7m0mysb0v47dqjmnvfc25z84rq"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/ahungry/color-theme-ahungry")
+ (synopsis "Ahungry color theme for Emacs")
+ (description "Ahungry theme for Emacs provides bright and bold colors.
+If you load it from a terminal, you will be able to make use of the
+transparent background. If you load it from a GUI, it will default to a
+dark background.")
+ (license license:gpl3+)))
+
(define-public emacs-smartparens
(package
(name "emacs-smartparens")