summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorng0 <ngillmann@runbox.com>2016-09-27 16:24:29 +0000
committer宋文武 <iyzsong@gmail.com>2016-10-01 10:22:31 +0800
commitf1b61e26ae886a533fba6220fc55a5f371c00078 (patch)
tree32e530dc203fd72a67cc36b2f894e37a02494dac /gnu/packages/emacs.scm
parentdf0e8a239bfee0fc1f429a133797251238c76969 (diff)
gnu: Add emacs-rudel.
* gnu/packages/emacs.scm (emacs-rudel): New variable. Signed-off-by: 宋文武 <iyzsong@gmail.com>
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index df9f4496fb..4a20f0c1a5 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016 ng0 <ngillmann@runbox.com>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Alex Vong <alexvong1995@gmail.com>
@@ -2231,6 +2231,30 @@ perspective only its buffers are available by default.")
;; the Expat license.
(license license:gpl3+)))
+(define-public emacs-rudel
+ (package
+ (name "emacs-rudel")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://elpa.gnu.org/packages/rudel-"
+ version ".tar"))
+ (sha256
+ (base32
+ "0glqa68g509p0s2vcc0i8kzlddnc9brd9jqhnm5rzxz4i050cvnz"))))
+ (build-system emacs-build-system)
+ (home-page "http://rudel.sourceforge.net/")
+ (synopsis "Collaborative editing framework")
+ (description
+ "Rudel is a collaborative editing environment for GNU Emacs. Its purpose
+is to share buffers with other users in order to edit the contents of those
+buffers collaboratively. Rudel supports multiple backends to enable
+communication with other collaborative editors using different protocols,
+though currently Obby (for use with the Gobby editor) is the only
+fully-functional one.")
+ (license license:gpl3+)))
+
(define-public emacs-hydra
(package
(name "emacs-hydra")