summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-05-27 01:26:09 -0400
committerMark H Weaver <mhw@netris.org>2018-05-27 01:26:09 -0400
commit1640f16e7888291227d11647dbb5f83ad5d138a1 (patch)
treebf979aa4e6538b8261762cfbb80512ebb023b016 /gnu/packages/emacs.scm
parent0ff4e49a95d8a54cd5508f441b927a670d348519 (diff)
parenta4e45acdc07fc3faf2844b3658ee31ebc538bd1c (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 9c759510a8..8c28b252dc 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10534,3 +10534,28 @@ Unless you're using @code{use-package}'s hook keyword, you can enable the
autosuggestions with:
@code{(add-hook 'eshell-mode-hook #'esh-autosuggest-mode)}")
(license license:gpl3+)))
+
+(define-public emacs-desktop-environment
+ (package
+ (name "emacs-desktop-environment")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DamienCassou/desktop-environment.git")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1fal3yfmqg10cb53qsf5gsq2gvyz9w16wmlpnpjwjzwnjfn6l73r"))))
+ (build-system emacs-build-system)
+ (home-page "https://gitlab.petton.fr/DamienCassou/desktop-environment")
+ (synopsis "Control your GNU/Linux desktop environment from Emacs")
+ (description
+ "This package helps you control your GNU/Linux desktop from Emacs.
+With @code{desktop-environment}, you can control the brightness and volume as
+well as take screenshots and lock your screen. The package depends on the
+availability of shell commands to do the hard work for us. These commands can
+be changed by customizing the appropriate variables.")
+ (license license:gpl3+)))