summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-07-03 18:53:33 +0200
committerAlex Kost <alezost@gmail.com>2016-07-04 10:14:18 +0300
commit7034791aa25db02e392495c44d68a5de937bdf7a (patch)
treea42deb0a19d4fd974f65148d0ba0fbf68460ca6e /gnu/packages/emacs.scm
parente446182e38cd9aa7634304b13bdbcbd07d1b4c81 (diff)
gnu: Add emacs-eprime.
* gnu/packages/emacs.scm (emacs-eprime): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 5796b97592..db88df16a2 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -2076,6 +2076,28 @@ Emacs default configuration in uncontroversial ways that nearly everyone can
agree upon.")
(license license:gpl3+)))
+(define-public emacs-eprime
+ (let ((commit "17a481af26496be91c07139a9bfc05cfe722506f"))
+ (package
+ (name "emacs-eprime")
+ (version (string-append "20140513-" (string-take commit 7)))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://raw.githubusercontent.com"
+ "/AndrewHynes/eprime-mode/"
+ commit "/eprime-mode.el"))
+ (file-name (string-append "eprime-" version ".el"))
+ (sha256
+ (base32
+ "0v68lggkyq7kbcr9zyi573m2g2x251xy3jadlaw8kx02l8krwq8d"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/AndrewHynes/eprime-mode")
+ (synopsis "E-prime checking mode for Emacs")
+ (description "This package provides an E-prime checking mode for Emacs
+that highlights non-conforming text. The subset of the English language called
+E-Prime forbids the use of the \"to be\" form to strengthen your writing.")
+ (license license:gpl3+))))
+
(define-public emacs-smex
(package
(name "emacs-smex")