summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-07-02 23:44:33 +0300
committerAlex Kost <alezost@gmail.com>2016-07-04 10:14:18 +0300
commitc1562e3de145780f9eea3bffd7e9ceffc34d6ec7 (patch)
tree0bd3743b83d41cebcb012fb2fa6ce7d1d47e09b7 /gnu/packages/emacs.scm
parent7012e2c7164bb8dcde42c61a7e29a428fc3e8c5e (diff)
gnu: Add emacs-magit-popup.
* gnu/packages/emacs.scm (emacs-magit-popup): New variable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 579fb65850..5796b97592 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -561,6 +561,31 @@ operations.")
support for Git-SVN.")
(license license:gpl3+)))
+(define-public emacs-magit-popup
+ (package
+ (name "emacs-magit-popup")
+ (version (package-version magit))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://raw.githubusercontent.com/magit/magit/"
+ version "/lisp/magit-popup.el"))
+ (file-name (string-append "magit-popup-" version ".el"))
+ (sha256
+ (base32
+ "144nl7j5mn86ccan6qxgg40bsxpkbc83vwnhd5y657gqki74972r"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)))
+ (home-page "https://github.com/magit/magit")
+ (synopsis "Define prefix-infix-suffix command combos")
+ (description
+ "This library implements a generic interface for toggling switches and
+setting options and then invoking an Emacs command which does something with
+these arguments. The prototypical use is for the command to call an external
+process, passing on the arguments as command line arguments.")
+ (license license:gpl3+)))
+
(define-public haskell-mode
(package
(name "haskell-mode")