summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-01 09:49:47 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-02 16:02:51 +0200
commite3740109236daaa73331e6d8077d7eaa0face97e (patch)
treebe333ea5b889a96fe3a5f735200a821205e40fb5 /gnu/packages/emacs.scm
parentac85107c9fe0e6224444fad4275df7d2146d3abb (diff)
gnu: Add emacs-evil-org.
* gnu/packages/emacs.scm (emacs-evil-org): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index fe9ac7b2f6..5c64999798 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10721,3 +10721,37 @@ in Emacs+Evil. It allows you to select and edit matches interactively,
integrating @code{iedit-mode} into Evil mode with an attempt at sensible
defaults.")
(license license:gpl3+))))
+
+(define-public emacs-evil-org
+ (let ((commit "b6d652a9163d3430a9e0933a554bdbee5244bbf6"))
+ (package
+ (name "emacs-evil-org")
+ (version (git-version "0.1.1" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Somelauw/evil-org-mode")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "176hrw7y7nczffbyhsa167b8rvfacsmcafm2gpkrdjqlrikbmrhl"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-evil" ,emacs-evil)))
+ (home-page
+ "https://github.com/Somelauw/evil-org-mode")
+ (synopsis "Evil keybindings for Org mode")
+ (description
+ "This package adds supplemental Evil mode key-bindings to Emacs
+Org-mode. It features:
+@itemize
+@item normal, visual and insert mode bindings;
+@item key bindings organised in key themes;
+@item operators like > and < to work on headings;
+@item text objects;
+@item table support;
+@item calendar (date selection) support;
+@item agenda support.
+@end itemize\n")
+ (license license:gpl3+))))