summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-06-12 22:02:04 -0400
committerLeo Famulari <leo@famulari.name>2016-06-12 22:09:26 -0400
commitee86e7e14859533045e1f7727ae731ba6ba72daf (patch)
treea5f51a9c4859a3242b46876797b98e77a5a7506e /gnu/packages/emacs.scm
parent8af5cac527eee03005f3809578a0d8258a878f95 (diff)
parentfe585be9aa8f5158a7dfb6477d19ece3d643dec3 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 386f91aebc..a8b5018edb 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
+;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1925,6 +1926,28 @@ matching delimiters, orient yourself in the code, and tell which statements
are at a given level.")
(license license:gpl3+)))
+(define-public emacs-rainbow-identifiers
+ (package
+ (name "emacs-rainbow-identifiers")
+ (version "0.2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://raw.githubusercontent.com/Fanael"
+ "/rainbow-identifiers/" version
+ "/rainbow-identifiers.el"))
+ (file-name (string-append "rainbow-identifiers-" version ".el"))
+ (sha256
+ (base32
+ "0325abxj47k0g1i8nqrq70w2wr6060ckhhf92krv1s072b3jzm31"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/Fanael/rainbow-identifiers")
+ (synopsis "Highlight identifiers in source code")
+ (description
+ "Rainbow identifiers mode is an Emacs minor mode providing highlighting of
+identifiers based on their names. Each identifier gets a color based on a hash
+of its name.")
+ (license license:bsd-2)))
+
(define-public emacs-ido-completing-read+
(package
(name "emacs-ido-completing-read+")