summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-07-23 18:58:26 +0200
committerFederico Beffa <beffa@fbengineering.ch>2015-08-01 12:37:14 +0200
commit48dbeef733b60299b8b54f64a4b1c6676b86d8fc (patch)
tree048e4b98db474fb2068ad67c9dcd694a30c42e06 /gnu/packages/emacs.scm
parent3a0b1b9afcf1cf2ee9a108724a8484237c95d3b7 (diff)
gnu: Add emacs-ob-ipython.
* gnu/packages/emacs.scm (emacs-ob-ipython): New variable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c2a9bb6c5c..b73d80c863 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -983,3 +983,24 @@ strings.")
(description "This package provides an Emacs library for working with
files and directories.")
(license license:gpl3+)))
+
+(define-public emacs-ob-ipython
+ (package
+ (name "emacs-ob-ipython")
+ (version "20150704.8807064693")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (commit "8807064693")
+ (url "https://github.com/gregsexton/ob-ipython.git")))
+ (sha256
+ (base32
+ "1scf25snbds9ymagpny30ijbsg479r3nm0ih01dy4m9d0g7qryb7"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-f" ,emacs-f)))
+ (home-page "http://www.gregsexton.org")
+ (synopsis "Org-Babel functions for IPython evaluation")
+ (description "This package adds support to Org-Babel for evaluating Python
+source code using IPython.")
+ (license license:gpl3+)))